ConvertXToDVD: Unsupported encoder

ConvertXToDVD gives me an “Unsupported encoder” error. I’ve found one reference on the web: “read the FAQ”, but I cannot find this error in the ConvertXToDVD FAQ. Any suggestions?

Do you have latest DirectX installed?
Can you watch DVDs on your system?
Is destination directory different than where originals are?

CxD is complaining about codec to encode DVD-MPG2; so it looks like first two options need to be checked.

  • I just installed the latest DirectX version to no avail.
  • I can view DVDs and the individual .VOB files that make up my project with Windows Media Player, so the decoder part seems allright. The “video preview” of ConvertXtoDVD also shows correct stills.
  • I do not have the same input and output dirs.

The message seems to indicate a missing/incorrect mpeg2 encoder. I thought that such an encoder was part of ConvertXtoDVD? So how can it be missing?

I have installed ConvertXtoDVD on another Windows XP computer with the same result (Unsupported encoder for output stream #0). What am I doing wrong?

Incidently, I want to use ConvertXtoDVD to merge 2 “half sized DVD’s” generated by a Sony DVD camcorder (105e) into a single normal video DVD.

Hi there,

If all you want to do is join .VOB files to 1 new DVD, you can use [B]DVDShrink[/B] in [U]Re-Author mode[/U].

Load all .VOB files, Re-Author, output = 1 new DVD !

My 2 cents…

Sorry; closer inspection of log shows that stream #0 is Dvdsub - Try opening first vob, then deselect that dvdsub.
It might be uncompatible sub.

I wouldn’t be suprised if the subtitle stream was the culprit: the Sony generated VOBs seem “substandard”, given that my Linux tools also barf on them (something about “illegal timestamps”).

But how dow I deselect the dvdsub? (see screenshot). If I click on “#1 - Subtitle: dvdsub, Offset 0 ms”, I can only change the offset, not delete the thing.

Sorry, forgot to add the screenshot, here it comes!


Try clicking on that subtitle selection above - it shows 0 streams, clicking it should open available languages. Select one. (or right click on that selection and delete subs)

Sorry, clicking doesn’t do anything (as does double, triple or quadruple clicking on it :bigsmile:). I can rightclick on the "Subtitle (0 stream) entry, and then a menu appears with 2 options:
“Add Subtitle Channel” and “Subtitle Options”.

The former opens a file browser, the latter just opens the “Settings” window with the “Subtitle” tab selected. I think that both options are not what I’m looking for.

I even tried adding some random subtitle stream downloaded from the web just in case ConvertXtoDVD cannot handle the “no subtitle case”. No luck, still the same error. I can delete that stream just fine with the same result: error when I try to Convert.

Do I need some encoder for subtitle streams?

Bytheway cougar_ii, DVDShrink works ok so I have a temporary solution, but I would really like to add a nice menu to the DVD. ConvertXtoDVD seems to have a nice simple GUI to do this :slight_smile:

Dvdsub seems to be treated differently - it is not added as subtitle channel, so you can’t remove it with current version.
I’ll try to get this to develeopers.

Sorry for being late on this problem. Subtitles are currently handled in ConvertX only if they are externally provided. I mean, only if they come from a different file. The subtitle entry shall be refered to “external subtitles”, internal one doesn’t appear there.
Right now, DVD subtitles directly embedded inside a source VOB are discarded (in fact, VOB support as input is very incomplete at this time).