Consistent problem with ImgBurn and Samsung 203B

I’m getting a consistent error with ImgBurn when I burn a dvd video. This is the error message when finalizing the disk:

‘WaitImmediateIO’ Deferred Error - (0/2) - Program Memory Area Update Failure

If I retry immediately, the disk is finalized properly and plays correctly.

Anyone know what is going on? It happens in both my XP and Vista partitions.

I’ve had some problems here with ImgBurn included but i have not traced it down yet. Bad thing about it is ImgBurn has not updated in awhile so it seems it has to be something else.

XP Pro here.

My problem has to do with making .iso files and burning them.

So i’m installing apps till i find it. ImgBurn included. Also makes me wonder if i have a corrupt ASPI layer :confused:

If the firmware is already up-to-date, all you can do is switch media - to something from Verbatim / Taiyo Yuden (if you’re not already using it!).

At the moment the drive is just running into issues at the end.

I have the latest firmware and the only disks I have used so far are Yuden 000 T02 and Verbatim brand MCC 004, which leaves me with no options as far as I can tell. At least it is not a fatal error, and I can get them finalized.

Will try a new firmware if/when Samsung decides to release one.

Thanks for the reply LUK.

FYI, I generally use TYG02 in mine and haven’t run into that issue as of yet.

[QUOTE=LIGHTNING UK!;1932144]…At the moment the drive is just running into issues at the end.[/QUOTE]First of all, thanks for all your great work LIGHTNING UK!. :clap:

But to blame finalization of disc on firmware or media must be kinda surprizing for the knowledged ones.
It’s the burning program (and of course drives own position “self-check” capability) that tells drive where to start burn data and how much of space in lead-in should be spared for what we in general speaking call TOC.
Both software and drive itself must be able to keep size of “reserved” space for TOC in lead-in in mind/memory.

To put all this simply, the area on discs lead-in (library) to write of what data been burned on disc is too small and the disc can’t be finalized.
And IIRC the area in question differs between dash and plus media.

Ok, you clearly have a far greater understanding of these things than I do so could you please tell me what I’m supposed to be doing?! (Everything I do is ‘self taught’ :frowning: )

Why would the ‘area’ be too small?

When I write, I just start at LBA 0 and continue until I’ve written all the data. Then, on DVD+R (as used here), I send the commands to:

  1. Close the track.
  2. Finalise the disc.

I don’t know of any other way to do it, nor do I know what I’m not doing that perhaps I should be.

So please do feel free to enlighten me! The way I’ve always seen it is that when the drive errors out like that, IT had the problem doing something I told it to do - it doesn’t have a problem being told to do it though. Why if it’s a generic issue on my part am I not seeing it more often?

As a side note, would the ‘DVD+R Reserve Track’ option in the settings make any difference?

Couldn’t it be some interface (controller) issue also?
Unfortunately, there are many SATA controllers that have issues with SATA ODD, so this might also apply to the system of Kerry56. Maybe he posts what SATA controller he is using for his drive and give some information about the operation mode and drivers used for his controller.

First of all, I never said there is anything wrong with ImgBurn. :slight_smile:
But to blankly blame PMA errors on media and firmware is making things to simple.

[I]I’m no expert on this and I’ll try to keep further discussion simple and non technical as possible.[/I]

Program Memory Area (PMA) is a section on disc where a copy of Table Of Content (TOC) is burned/stored prior burning data to disc. When drive finalizes the disc the a “copy” of TOC is read from PMA area and written back to discs lead-in.
This ofcourse applies only when you write disc in Track At Once (TAO) mode.

When disc is written in Disc At Once (DAO) mode the PMA area is not used (not AFAIK). Disc TOC is written in lead-in area when finalizing disc, after data section been burned.

Therefor the first thing we can do when getting “PMA errors” is to switch to DAO write mode. :wink:

Ok but what happens if Kerry56 was/is already using DAO? It is the default after all and the TAO write type isn’t even an option on DVDs (or within ImgBurn full stop). Perhaps ‘Incremental’ is like TAO in that respect?

When the software has such little input on the burn and what gets written when and where, I don’t see how it can be anything BUT the drive/firmware/media at fault.

After all, all the software does is send some 'Write (10)'s followed by a ‘Sync Cache’ and a couple of ‘Close Track/Session/Disc’ commands!

Don’t know if I’ll be any use in this discussion, but I’ll provide a few more facts. The board I’m using is an Abit IP35E, Intel P35 Express / ICH9 chipset. I’m using the standard Microsoft and Intel drivers that were included with the cd that came with the board. Nothing unusual there. Latest bios also, though there is a newer beta bios available I believe.

I was using default settings in ImgBurn, so DAO should have been in effect.

I would try different media, but unfortunately, I only have the two types at the moment.

I will add that the last movie I burned did so without the error popping up. That was the first time in the last six or seven burns I didn’t have to retry the finalization.

Ah, I have the IP35 Pro :slight_smile:

Mine’s on port 5 of 6, the first 4 are hdds, the last has an LG GSA-H62N on it.

The controller is running in the std (S)ATA mode rather than RAID or AHCI.

In case you’re running AHCI, I assume you’ve tried the latest Intel Matrix driver (direct from Intel) ?

I burnt 5 YUDEN000-T03’s lastnight as tests, using MAX, 18, 16, 12 and 8x. All of them worked without issues.

Today I’ll repeat the tests using YUDEN000-T02 (and slower speeds obviously!). I’ll keep you posted.

No raid with the IP35E, so my controller is slightly different from yours—the ICH9 instead of the ICH9R. So, yes, I’m running standard SATA mode.

No SATA hard drives in my computer yet, I had some good IDE drives from my last rig. My burner is on SATA 1 port.

Tried another test burn and didn’t get the error this time either. Maybe I just have a slightly quirky drive and there isn’t any more to it than that.

I did do another 4 test burns with the YUDEN000-T02 media, at 4x, 6x, 8x and 12x - again, no failures I’m afraid :frowning:

Kerry56 has this always happened since you installed that drive? Meaning if you take the drive out then no problems with other drives or just use a different drive?

Also i have read here that some people are having trouble with finalizing since they used an app to stop auto run with their drives. Sorry i don’t remember the particulars.

Nice to have your help here LUK! :clap:

This is the only SATA optical drive I have rolling, so it has been in since I built this rig. There is no room for my IDE opticals, since I am using both ports for my hard drives at the moment. I will eventually get some SATA hard drives in here, but not before I need more storage space.

I do have autorun turned off. I always turn off autorun on my computers and have never run into a problem like this before.

@Lightning UK
Thanks for looking into this for me. Appreciate the help. But I’m still getting good burns even when the problem pops up, I just have to take an extra step to finish the disk. I think it is just a peculiarity of this individual drive.

Not that it’ll help you right this second but the next ImgBurn does actually perform 3 retries of those commands - so at least you won’t have to do anything manually once you upgrade :wink:

You’ve probably also noticed that when the finalisation doesn’t complete the first time around, the booktype isn’t changed - the drive forgets that it’s meant to do it. That too has been worked around in the next version.

I 15:28:45 Closing Track…
I 15:28:48 Finalising Disc…
W 15:29:06 Potential ‘WaitImmediateIO’ Deferred Error - (99%, 0/3) - Program Memory Area Update Failure
W 15:29:06 Finalise Disc Failed! - Reason: Program Memory Area Update Failure
W 15:29:06 Retrying (2 of 3)…
I 15:29:20 Image MD5: 599291c0cfa67c16af12d143ace6a96c
I 15:29:24 Operation Successfully Completed! - Duration: 00:05:49
I 15:29:24 Average Write Rate: 13 852 KB/s (10.0x) - Maximum Write Rate: 16 673 KB/s (12.0x)

Hi got this too now, using latest imgburn on samsung 203B (tdk cheap dvd+r) vista32 asus p5b dlx, but dvds seems to play ok so thats good :slight_smile: .
Planning on buying a gigabyte x38 motherboard hope these errors not repeating.

[B]tdk [U]cheap[/U] dvd+r[/B] Skip them.