Connection of the 1620 causing slow burns?

vbimport

#1

I just bought a 1620 OEM and flashed to B7P9. My computer has only one IDE socket on the motherboard (Its got 2 SATA connections though). I’ve got one HD connected through SATA, and a second large drive connected on the only IDE cable along with the Benq drive. I’ve got both jumpered to cable select. Windows recognizes all drives, however when I boot up, I get a message saying the larger HD (primary slave) is not detected. I burned my first DVD yesterday and it took about 48 minues at 12x. I was using a TDK 8x disc I got from Best Buy. The instructions were a little complicated about the jumper settings, but I’ve tried the dvd drive on master and the hard drive on slave and that did not seem to work, although come to think it gave me the same error about not being able to detect a drive upon boot, but that time it couldn’t detect the dvd drive. Any thoughts?


#2

Do not use CS (cable select). It is error-prone on most systems. Jumper the drive at the end of the cable to master and the other to slave, if possible. The other way round should work, but BenQ recommends to do it this way and I think (hope) they know what they tell us.

And dont forget to set both drives on that ide port to “AUTO” or so in the PC BIOS for the first tests…

Maybe the CS setting also made the flash procedure fail … in this case, look at
http://tdb.rpc1.org/
and their DOS flasher / winflasher to revive the drive.

CS is evil :wink: !

ANOTHER THING: Make sure the HDD on the IDE bus is NOT jumpered to master or CS - best config is one drive (end of cable) as master and the other one (in middle of cable) as slave. Normally, other configs may work but errors may be hard to find.

If possible, be sure to use a good 80pin cable. I have two writer on a 40pin std ide cable because the 80pin I had was a little bit too short, but I will change this ASAP.

Good luck.


#3

Thanks for the reply, I’ll change the jumpers now. I think the only settings I have in my BIOS are either on or off. I’ll look for an auto. I’m not sure if I have a 80 pin or 40 pin cable. I did buy a mad dog round ide cable for this though because the stock was too short. I’ll look into the firmware reflash. Would this be caused if I did the flash while not in safe mode? The DVD I burned did play in my cheap dvd player, so at least i didn’t totally screw the drive up.


#4

I think round cables are always 80ipin, at least I never saw sth different. If it is labeld with “UDMA 133” or so it is definitely correct. If you burned a CD after flashing your drive is ok and you dont have to correct anything but the jumpers, I guess.

This safe mode thing may be for the most paranoid ( I always thought that was me :wink: ) but I never did that and it worked well though. Will consider it the next time, anyway, but until now everything is ok…

All the best to yer!

PS: ala42s post below is to be taken serious as well !!!


#5

When burning a DVD, do not take the source files from the hard disk that is on the same ide bus as the burner, the ide bus protocol is a bit ill. Check the burst rate transfer speed to your burner with cdspeed, it should be around 23 MB/s. If it is much slower, check your DMA settings.


#6

Well, I’m back. I changed the BENQ to master and the HD to slave. Booted up and right after I turned it on it gave same message about primary slave not found. No auto in BIOS, only off and on. I did wonder about transfering the files from the same cable. I’ll store the files on the SATA drive before transfer next time. DMA is enabled on the BENQ, but under the proberties of the HD it says its off (This was what it said before the jumper switch). I actually can’t remember how to check that now, so I’m not sure if it changed. Thanks for the info. I’ll post another update after I burn another disk. So, just to make sure, I shouldn’t reflash the firmware? Thanks again everyone.


#7

Here are the instructions on how to check the DMA settings.


#8

Thanks ala42. I checked that and they both say DMA if available. But in Nero’s InfoTool, it says DMA off for the HD. I don’t know. Its a new drive, western digital 160GB. Strange. Anyway, thanks for the help.


#9

Whats the make of your compu and motherboard?

Goto manufacturer homepage for latest chipset/IDE drivers and BIOS.
A read in mobo manual can also help to understand BIOS settings.

BTW, there is no need at all to flash your DVDRW… :wink:


#10

agree with ala42…try to keep your data source drive on different cable to your drive…

suggest this way…but then have to get a SATA drive…or grab a cheap PCI IDE card off ebay

SATA 1>> OS HDD
SATA 2>> Data HDD

MAster IDE >> DW1620
Slave IDE >> for new benq ??..


#11

Post the text output of nero infotool as text file attachment.