Confused about region locks

vbimport

#1

Hi there.

I’ve got an Optiarc AD-7240S drive which was originally region locked to region 2. I’ve been able to flash it using the 1.04 RPC1 and Auto firmwares but I’ve only had partial success playing the region 1 discs I’ve tried in it. With the drive set to Auto I’m able to play my region 2 discs and one of the R1 discs I’ve tried in it (Fight club, 2-disc special edition) but a newer one (Avengers, the DVD from the DVD and Blu-Ray version) won’t.

Having read around a bit in these forums I think that some or all of the problem is caused by the software not being fully compatible with region-free disc (I read that even if the drive ignores the region settings, the software can go ahead and pay attention) so I assume that the solution is to change my software. I’m currently using a mix of Windows Media Center (Win 7), Media Player Classic and VLC Media Player but I guess that the two free versions are probably using the codecs provided by WMC and are therefore equally locked down.

What’s the best way to get around this problem? I’d like to fix it so that it’s seamless, as I’m planning to build a dedicated media centre PC and I’d like it to be able to play anything I put in its drive.

Thanks in advance,


#2

the only thing i can think of is to use something like mplayer for windows: http://mulder.brhack.net/#mplayer

another possible solution would be to use a different DVD Navigator. dslibdvdnav is one: http://sourceforge.net/projects/dslibdvdnav/


#3

Running a decrypter may be the answer .
I have anydvd & with it running all the players I have will play DVD’s.
I don’t have any not in my region . Region free burned DVD’s play on my OS even without anydvd running.
For a freeware I would give DVDFabs’ Passkey Lite running & see if it allows your R1 DVD’s to play.