Confirmed 716A Firmware Bug

vbimport

#1

I’ve got a PX-716A, DLA 0304. It came with firmware version 1.04 and has worked very well in my Dell computer with a Dell motherboard, P4 3.6 GHz, Intel 925XE chipset. However, if I flash the firmware to version 1.04u (the latest), the drive will not burn CDs. When I use Nero 6, the program shows that the drive’s buffer receives no data and my computer completely crashes so that it needs a hard reset.

I have flashed back to 1.04 and the problem disappears. I have also confirmed this problem on another 716A DLA 0203. I’ve also tried this with both Cable Select and with setting the drive’s jumper to master. It’s definitely related to the new firmware. Plextor said that the new firmware addressed data corruption on certain ASUS motherboards. I wonder whether they introduced new problems with other brands of motherboards. I’m concerned that the upcoming version 1.05 may carry over this problem.

I know that many (maybe even most) of you have not experienced any problems with version 1.04u, but I’ve seen posts by others who have had problems. Luckily, I’m able to reflash back to 1.04 and not end up with a paper weight.

Eric


#2

Since I’ve noticed a few posts about people having problems w/1.04u I opted to pass on it and stick with a good thing. I didn’t think there was an issue w/ my motherboard. Hope 1.05 is a keeper. :rolleyes:
I must add these are ( 716a’s ) doing a fine job for me. :bigsmile:


#3

I believe 104U firmware addressed data corruption for the ASUS A8N Mobo. Intel’s 925XE is a newer chipset I believe. I am looking at the new Asus 925XE for myself and will be watching this post with interest for compatability issues. Maybe talk directly to Plextor about this issue. Maybe they can help


#4

I’ve only one thing to say:
If you find a bug, report it to the company who made the hard-/software.
But you have to include the specs of your system (CPU, Mainboard, RAM, other drives, other Hardware, OS and eventually other Software.)


#5

I did email Plextor support yesterday about this. But I’m sure they give their software engineers the weekend off. :cool: I’ll report back if I hear anything from Plextor.


#6

Sounds like a Dell Dimension XPS Gen 4, possibly? I am using the 716SA TLA #0304 on my Dell Dimension XPS Gen 3. No issues making the drive burn CD-Rs, however, CD-R quality is another issue. The SATA version of the drive works great with Intel chipsets like the ones Dell uses in their latest systems. See my CD-R quality post.


#7

I confirm the problem, I could not write an iso image in DAO mode, with the 1.04u firmware. Actually the drive wrote the leadin, but stops after. It occurred both in Windows and Linux. Under Linux, kernel logs report:

Mar 5 12:23:32 shuttle kernel: hdc: status error: status=0x58 { DriveReady SeekComplete DataRequest }
Mar 5 12:23:32 shuttle kernel: hdc: status error: error=0x00
Mar 5 12:23:32 shuttle kernel: hdc: drive not ready for command
Mar 5 12:23:32 shuttle kernel: hdc: status timeout: status=0xd0 { Busy }
Mar 5 12:23:32 shuttle kernel: hdc: status timeout: error=0xd0LastFailedSense 0x0d
Mar 5 12:23:32 shuttle kernel: hdc: DMA disabled
Mar 5 12:23:32 shuttle kernel: hdc: drive not ready for command
Mar 5 12:23:32 shuttle kernel: hdc: ATAPI reset complete

And indeed, DMA was deactivated (as seen with hdparm). I guess this also occurs under Windows and would explain why people were having problems reflashing (if DMA was necessary, as I could read). Rebooting in Linux was reactivating DMA automatically, I don’t know for Windows though.

I flashed back to the original 1.04 and it worked again.

Plextor company, please, instead of doing an overpriced Plextools XL, do not introduce new bugs in your firmware, thanks. Also, that would be clever to rename new firmwares 1.04.1 etc… instead of 1.04u which does not differenciates from the original 1.04 after flashing.

EDIT : my hardware is a Shuttle SB75G2, with a i815e chipset and ICH5 SATA IDE controller.

EDIT2: CD-RW are not written properly with firmware 1.04 too (1.04 and 1.04u). Plextor, please fix this !!! :a


#8

I have sent a report to Plextor Europe. I hope they will do something.


#9

I received a very quick response from Plextor tech support. Here is what was said:

“For you system, stay with the the original 1.4 firmware version, especially if the drive is working. Yes, the 1.4u firmware to written to cope with an oddity in a certain series of Asus m/b’s. I will have the engineering staff to look at the Intel chipset that you are referring. Check the Plextor website periodically for a new plextor firmware update.”

I have to say that I am very impressed with such a responsive company. I’ll stay with version 1.4 for now and hope that 1.5 will work with the Intel 925XE chipset.

Eric


#10

it may not be all intel chipsets i have the older 845 chipset and I have had no problems like have been talked about with 1.04u


#11

Hi, my chip is the 875 actually, and the new firmware gives me trouble.


#12

Same chipset 875, No Problems with 104U. There are going to F/W issues for a while I would guess, My other Drives won’t read any thing the Plextor burns (DVD) My Nec might and might not and Lite Ons won’t, believe it is a Plextor firmware problem as well. Tried both 104 and 104U


#13

I’m running 1.04u and an Intel 875 motherboard, no problems. PX-716 is on it’s own IDE channel, no slave.


#14

I have an asus p4b533e deluxe with 845 chipset and firmware 1.04u with no problems, I’ll try to test it on a 925 based motherboard.


#15

I also have a Intel 875P Chipset and a PX-716SA. No issues with both versions of the 1.04 firmware.