Computer doesn't recognize BenQ 1655 after firmware upgrade

vbimport

#1

I have a BenQ 1655 in external enclosure (Plumax with Prolific PL-3507), and connected via USB2.0 to Windows XP laptop. I upgraded the drive’s firmware to BCHB, then decided to go back to BCDB.

I ran the EXE file for BCHB firmware, and it said “upgrade complete” (or something to this effect). But then the computer hangs while rebooting at “Shutting down computer.” After about 2 minutes, I unplugged the USB cable, and the computer rebooted. Everything worked fine.

The same thing happened again when I went back to firmware BCDB. It hang at “Shutting down computer” again so I unplugged the USB cable, and the computer rebooted. But now, the computer doesn’t recognize the drive. The enclosure’s light turn on green. But when I push to eject button, the tray doesn’t open.

The only thing I did differently the 2nd time around was that I unplugged the USB cable after about 30 seconds.

I have done a System Restore, and still nothing.

Have I killed my BenQ for good? :sad: Please help.


#2

have you tried connecting it to another computer via IDE channel instead of USB computer and trying to see if it shows up there while restarting in safe mode>? This thread might help a tad;
http://club.cdfreaks.com/showthread.php?t=141350&highlight=flash+fail
http://tdb.rpc1.org/


#3

Thanks. I only have this one laptop computer.

Well, I undo System Restore.

Then I left the drive connected to the computer. Suddely, perhaps after 20 minutes, the “Found New Hardware” pop-up appeared, and then said “a problem occurred during installation… device may not work.” I checked the Device Manager, and a new “USB Mass Storage Device” showed up. I right-click and chose “Property” and, at first, it said, “No drivers are installed for this device.” Then a minute later, it changed to “This device cannot start.” So I “Uninstall” the device and chose “Scan for hardware changes.” The “Found New Hardware” pop-up came up again, but the same thing again.

This is a retail BenQ 1655 from Newegg. But it didn’t come with a disc containing any drivers (just the 1 disc with OEM Nero and QSuite). Thanks.


#4

Did you restart in safe mode on the computer and try running your original firmware that came with your drive??? Try that.

You can get the orignal firmware from here>
http://www.benq.co.uk/ServiceAndSupport/downloads/downloads.cfm?product=839&type=B


#5
  • Thread moved to the BenQ/Philips sub-forum *

#6

I have never used the computer in Safe Mode before. I just figured out. What should I do differently in Safe Mode? What does it mean, “running your original firmware that came with your drive”?

Anyway, I went into Device Manager, and then uninstall and install the drive. The same thing happens. :sad:

Actually, as I was rebooting into and out of Safe Mode, the computer hangs before “Windows is starting up”. Once I unplug the USB cable, then it started up. What’s happening? :frowning:


#7

That mean your system has compatability problenm with USB device you are using, If this USB device is USB2 then you better have drive for USB2 not 1.


#8

…The same thing happened again when I went back to firmware BCDB. It hang at “Shutting down computer” again so I unplugged the USB cable, and the computer rebooted. But now, the computer doesn’t recognize the drive. The enclosure’s light turn on green. But when I push to eject button, the tray doesn’t open…
Use the power on/off switch on enlosure or just unplug/plug power cord to enclosure and let drive to recycle.

Only “restarting” computer/windoze is not enough after a flash with drive in enclosure connected on USB/FW.


#9

You have two choices:

  1. Send your drive back for a refund or replacement. Since this was a flash with the official BenQ firmware you should be able to RMA it without problems.

  2. If you choose to keep the drive then you must test it on another PC connected as an internal drive on IDE. If the drive is recognized in the BIOS when Windows boots, press F8 a few times until you get the Safe Mode menu, then select the Safe Mode option. Windows will load and you will get a warning that it runs on Safe Mode, accept that. Your screen resolution will be much lower, that’s normal on Safe Mode. Then run the firmware flasher again. If the flasher doesn’t recognize the drive, it may still be salvagable in DOS mode but that’s a whole different ball game. Bottom line: If you have a friend that knows computers, now it would be a good time to call them.

If you choose to get a replacement make sure you don’t try to flash it again from your USB2 enclosure. Good luck.


#10

Thanks to everyone. Some good news. The BenQ drive is not dead. :smiley: I put it into another enclosure, and it worked perfectly including turn off (“safely remove hardware”) and turn back on. The firmware was as I last upgraded at BCDB.

So, I put it back into the Plumax (Prolific PL-3507) external enclosure, and tried Safe Mode again. At first, it said the same thing… “new hardware found… problem occured during installation.” But then after I logoff and back on, and surprisingly the drive showed up. :slight_smile: In normal mode, it showed up. But when I turned off the drive with Safely Remove Hardware, and turn back on, it was gone again. :frowning: So I went back into Safe Mode but it wasn’t there at all. :frowning: But in normal mode, it showed up again. :confused:

I noticed one thing different this last time. At “Found New Hardware” it says “ATAPI-6 Bridge Controller.” What is this? As you can see, all this is way over my head, and I don’t know anyone here to ask.

Anyway, I have included some info below which may be relevant. What should I do? I want the drive to work like before where I can turn off (“safely remove”) and then turn back on at any time. Thanks!

Nero InfoTool 3.00

Interface Information

Adapter 1

Description : Primary IDE Channel

Driver
Description : system32\DRIVERS\atapi.sys
Company : Microsoft Corporation
Version : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
Description : IDE/ATAPI Port Driver

Attached Devices
Description : Master: IC25N040ATMR04-0
Type : Disk Drive
DMA : On

Adapter 2

Description : Intel® 82801DB/DBM USB 2.0 Enhanced Host Controller - 24CD

Driver
Description : system32\DRIVERS\usbehci.sys
Company : Microsoft Corporation
Version : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
Description : EHCI eUSB Miniport Driver

Attached Devices
Description : BENQ DVD LS DW1655 USB Device
Type : CD-Rom Drive
Autorun : On

ASPI Information

System ASPI : ASPI file(s) are missing

wnaspi32.dll : 4.71 (0002) 45056 bytes July 17, 2002

Nero ASPI : ASPI is installed and working properly

WNASPI32.DLL : 2.0.1.74 164112 bytes October 26, 2004


#11

taylor5:

Maybe you need to update your Prolific PL-3507 firmware? If you have the Chip B and C, you can grab the latest PL-3507 firmware here: http://www.prolific.com.tw/eng/downloads.asp?ID=44

The latest flasher is rw_pl3507_icp_v23.zip and firmware is fw_pl3507B_d112805.zip.


#12

Unfortunately, all my friends and relatives around here are at a level where they think that I’m brilliant with computers. If they run into you folks here, they’d think that you’re gods. :bigsmile: When I have computer problems, I rely on the comfort of strangers. That is, you are my “friends that knows computer.”


#13

Yes, my Prolific chipset enclosure had the lastest firmware. But I just reflashed it anyway. Nothing changed.

I’m really sorry for all these lenghty posts. I try to be brief, but I also think that I need to give you enough info.

So far, this is the most noticeable pattern. In Safe Mode, after about 10 minutes, “USB Mass Storage Device” shows up in Device Manager, but the drive does not. Then I reboot in normal mode and the drive would be there in good working order. However, if I do “Safely Remove Hardware” and turn off the drive, then it does not show up when I power on the drive. However, if I shut down the computer and also turn off the drive, then turn drive on and boot up computer, the drive shows up.

Last night, when I put the drive in another enclosure, unplug (“safely remove”) and power on worked perfectly. So is my Prolific-chipset enclosure bad? But why? The problem occurred after I flashed the drive. Then perhaps the computer?

Where is the problem? The computer, the drive, or the enclosure.


#14

The only thing I can think of is a problem of the enclosure in combination with the new firmware. Looks like it fails to reinitialize the drive after you turn it off and then back on, and if it worked perfectly with the previous drive firmware then I can only deduct that it’s the new firmware that the enclosure chipset doesn’t like. If I was you, I’d try to flash back to original drive firmware and see if the Prolific works with it like it used to, but if you don’t want to risk a new flash just use your drive with the other enclosure. Good luck mate.


#15

CyberMan, you are brilliant! Thank you. Thank you. :flower: :flower:

You are right about BenQ firmware BCDB not working with latest Prolific PL-3507 firmware D112805. You have great deductive reasoning skills. :bow: (I also can’t believe that you read all my lengthy posts!)

I put the drive in the other enclosure (ALI-chipset), and flashed it with firmware BCHB. Then returned it into the Prolific enclosure, and now it is working perfectly.

I’m so happy. My Bytecc-brand ALI enclosure had other problems with the BenQ 1655 (Nero CD/DVD Speed could not scan, etc.)

But I wonder why I am the only one having this problem with firmware BCDB on the Plumax-brand Prolific enclosure? The number on the chipset is PL-3507 041333C.

Anyway, I can’t say thank you enough. :smiley: :flower: :smiley: :flower: :flower: :smiley: :flower: :smiley: :flower: :smiley: :flower: :smiley: :flower: :smiley: :flower: :smiley: :flower: :smiley: :flower: :smiley: :flower:


#16

You are not the only one that had problems with the BenQ 1655 firmware BCDB and earlier on the prolific 3507 (USB 2 & 1394A) chipset. I had so much trouble getting my drive to work properly that I had decided to remove it from the external enclosure and install it on an internal IDE port. Then firmware BCHB was released (May 2) and I upgraded the drive and now the it works much better in the prolific external enclosure.

Many drives don’t work properly in external boxes. The BenQ 1655 was my worst, until the upgrade to firmware BCHB, who knows what the next firmware update will bring? Next are the NEC ND-35XXA and ND-45XXA series drives. My LiteOn drives seem to work better in external enclosures, so you are always taking a chance using an external enclosure not supplied with the drive. Try to get packet writing software, InCD for example, to work on any of them. The external enclosures do not always translate the commands to the drives properly. Bios upgrades should preferably done on a regular IDE controller. If you are updating the boot code in the drive this is really a must!


#17

Sounds like external drives are more trouble
than they’re worth. :bigsmile:


#18

I have read a little bit about problems with drives in external boxes. I think I understand better now.

I only have one laptop computer, and I wanted a good burner with LightScribe on the cheap. It seems like the better drives (BenQ and NEC) are more challenging.

Well, it’s working great now. Also, in trying to figure out the problem, I have learned a whole bunh of stuff about the computer. Thanks to everyone for reading and replying. :flower:


#19

I use IDE to USB2 adaptors instead of enclosures and never had a problem using them on any of my drives so far, just plug at the back, plugin the power supply and go. I have two such adaptors of different brands and so far they both have been working flawlesly with both DVD and HD drives.


#20

With the USB2.0 to IDE adapter, how do you cover up the drive? I’m thinking of dirt problem and exposed wires. The drive will be kind of naked, no? :bigsmile: