Compatibility Issue - Hard freezes

vbimport

#1

I just got my Benq Retail DW1620 and it is freezing my computer prior to windows even booting up. Last night it booted up on several occassions and now it wouldn’t even boot into windows. Even in windows it would freeze, after 30 minutes or so. I flashed the motherboard to the latest BIOS and still the same thing. My brother has the same drive and everything is working fine, but he has a P4 system while I have an AMD system. I’ve tried different power supplies, different IDE cables, just the bare essentials, etc and still freezes. Now I know the DVD drive works(?) because the BIOS detects it fine, I was watching a DVD off of it, Windows sees it fine, all the good signs of a working drive.

System Specs
Antec Trupower 550
Abit NF7-S 2.0
Benq DW1620
Lite On 16x DVD ROM
Asus 52x CDRW
1 gig Patriot PC4200
2x 40 gig seagate barracuda’s
Radeon X800 Pro
Corsair HydroCool200
Audigy 2 ZS


#2

Have you tried to clear CMOS?
Do that and if this not change anything see your wires.
It seems like a motherboard issue.


#3

Make sure you roll back to the MS IDE driver if you have Nvidia’s IDE driver installed as it has compatability problems with DVD writers.

I would also double check your master/slave settings just to be sure there isnt a conflict or at lest test the writer on its own without any other device on the IDE chain.


#4

u using nForce’s SW IDE drivers? if so, pls revert back to MS’s IDE drivers coz benq 1620’s older firmware has problems wif them…


#5

I too had this exact same problem and I know how to fix it. It’s caused by a conflict with an early BenQ 1620 firmware and your motherboard’s Nvidia Nforce2 IDE driver.

  1. First, you should disconnect the BenQ 1620 and reboot your system. It should boot fine with the drive disconnected.

  2. The next step is to remove the nForce2 IDE driver. You should make sure you have installed the latest nVidia nForce unified drivers from http://www.nvidia.com/content/drivers/drivers.asp since they will allow you to selectively remove only the nForce IDE driver.

  3. Once you’re sure the latest Nvidia drivers are installed, and your machine has been freshly rebooted, go to the Control Panel and select the Add or Remove Programs entry. Select “Nvidia Drivers” from the list and click “Change/Remove”. A dialog box will appear titled “Remove NVIDIA Components”. Select “Remove Only The Following” and then check “NVIDIA IDE Driver”. Click “Remove” to remove the driver.

  4. Reboot the system to complete the Nvidia IDE driver removal. Note that the Microsoft drivers will automatically take over IDE duties.

  5. Shut down your system and reconnect your BenQ 1620. Restart your system and Windows will automatically boot fine now and your BenQ 1620 drive will work correctly.

  6. Update the firmware in your BenQ 1620. The firmware you have is old and does not work well in terms of DVD write quality, and does not properly support disc scanning. Recommended firmwares to upgrade to include either B7T9 or B7U9. Pick the one that works best with the discs you want to burn. If in doubt, choose the latest one first (the one with the higher letter “U” is the latest).

  7. Once you’ve updated your firmware to a newer version, you will be able to reinstall the NVidia IDE driver. This is optional, but I recommend it, since I believe that it is a bit faster than the Microsoft one (others will disagree on this point).


#6

Thanks guys for the quick replies! I was getting concerned there were no responses, but somehow after the vbulletin upgrade, I don’t get anymore e-mail updates. I will go test the suggestions, and post back. As for Master/slave conflict I did Master on Primary and Master on Secondary as well as cable select.


#7

Thanks for the replies, I followed Spartane’s suggestion of removing IDE SW driver as pointed out by tkte_85 as well, and flashed the drive. I’m using it for about 20 minutes so far, and hasn’t locked up.

Thanks :slight_smile: :bow: :iagree: :cool:


#8

Well I’m still having the same problems, using the B7U9 firmware, even without using the NVIDIA drivers. Spartane what firmware are you using? Oddly, I backed up a DVD and it didn’t crash.


#9

it should not crash…the bootup freeze is due to you using the nvidia ide drivers…all should be fine once you use ms windows ide drivers…


#10

Some people report performance increase with nvidia ide driver, but most have bad experience with them. Worse yet, some of them had to reinstall the system just to get rid of the driver since they can’t even boot into safe mode. Yes, it is THAT bad. So I suggest you get rid of the nvidia ide driver while you still can. If the problem persists even with M$ IDE driver, you are in troubles…


#11

At the moment I’m using B7T9, but I’ve also used B7U9 without issue. The problem you described is a known one and causes the exact issues that you detailed in your first post. Just replacing the NVidia drivers with the Microsoft ones would have been sufficient to completely correct that problem. Upgrading to one of the later 1620 firmwares would allow it to work perfectly with either set of drivers.

In your first post, you described a number of things that you previously tried in order to correct this issue. I’m assuming your system was stable prior to adding the 1620 drive. Could you have caused a different problem that somewhat resembles your original problem by your earlier troubleshooting attempts? Are the symptoms 100% identical to your original problem?

Did you add anything else to your system lately - at about the same time as you added the 1620?

Is your drive running in DMA mode? Are you sharing the IDE cable with another drive - if so, consider temporarily removing it to see if the problem goes away. Set the 1620 as IDE master if it’s not already to see if this has any effect.

Consider running a memory test program overnight to make sure your system is working correctly. Microsoft has an excellent one that I like at http://oca.microsoft.com/en/windiag.asp. It found problems for me that MemTest86 did not.


#12

Thanks for the input, I had not realized that the problem extended as far as some people can’t even boot up into safe mode. Now I learned something, that the IDE drivers are initalized prior to Windows booting up.

Yes Spartane, the system was completely stable before I installed the burner. I’ll try out the B7T9 firmware whenever I get a chance, as soon as I get enough money, I’ll be able to build my second computer where it’ll be my designated burner that will have my Plextor Premium.

Thanks for the help.


#13

I’d also suggest doing this:

  1. Click on Start and then Run
  2. Type in MSConfig and Click OK
  3. Click on the Startup tab at the top
  4. Disable everything running in the background, including Antivirus, software and restart the computer.
  5. Plug the BenQ in if it was disconnected and see if the computer will start up properly.

My dad had this same issue with a NEC ND3520A (pretty much the same problem anyway) and it ended up being something related to Norton’s Antivirus causing the problem.


#14

Thanks for the tip Braxas I’ll keep that in mind but I haven’t been able to try anything out yet. Been trying to backup some DVD’s with Shrink and DVD Decrypter, but asking questions will be in a different thread as this is not the one I should be doing it in.