Compaq HLDS GWA-4162B

vbimport

#1

Hi, I seem to be at a loss to update my firmware. I created the CD from hp and when it boots it simply fails with
“error reading from drive c: DOS area : drive not ready”
I am figuring is because i am running on ntfs, but I would like to update my firmware and I just cant figure out how come they release the update this way. It is extremely BS if you ask me, who runs fat32 anymore ?? If anybody can shed some light in this issue I would really appreciate it! Sincerely,Los

P.S -> I believe it is an LG , since all HLDS GWA drives were listed as LG, I wish I knew which version was mine :slight_smile:


#2

Can you post a link to the firmware provided by HP?


#3

http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?dlc=en&lc=en&os=228&product=483894&lang=en&cc=us&softwareitem=pv-32087-1

Also, before it gives me this error, the cd ( which is some sort of FREEDOS ) gives me an a20 address line error , something about xms . Dunno if this helps


#4

Well, I think i found the problem, but I cant understand how HP/COMPAQ didn’t test this. After looking at the messages clearer I saw the error actually comes from a flaw in the Freedos / FDXMS version they are using. THey are using the .9 Sand version and it clearly has a problem with the “a20” line error and therefore it doesn’t load.

"Changelog of FDXMS 0.91.Apples

  • FDXMS now only warns if it can’t disable the A20 line instead of refusing to load (bug 1352).
  • INT15 parameter added. "

They are using the .90 Sand version which has this bug.
Am i wrong to think that they are this stupid or do you think it is something else ?


#5

Thanks.

Step 1: Do you need to update?

Release Date: 2005-06-28 Version: E1.93

Description

This is a firmware update for the HLDS GWA-4162B 16X DVD(+/-)R/RW DL Drive.

Purpose: Recommended

Operating System:
Microsoft Windows XP Home
Microsoft Windows XP Media Center Edition
Microsoft Windows XP Professional

Fixes

  • Resolves hang that may occur when using Sonic Digital Media.

  • Resolves issue with audio playback when using Sonic Digital Media Home.

  • Improves disc writing when using Sonic RecordNow and EMC Dantz.

  • Reduces time Roxio takes to recognize a disc with an open session.

  • Resolves issue with editing CD/RW discs using Sonic MyDVD.

  • Resolves issue with Intervideo WinDVD recognizing LightScribe discs.

  • Improves writing strategy for Ricoh 2.4x dual layer media.

  • Added support for 2.4x dual layer DVD media from Philips and Ritek.

  • Improves handling of unrecognized 2.4x dual layer DVD media.

    Step 2: Does your system meet the following?

Operating system(s): Microsoft Windows XP

Download file size: 3.21M

System Requirements

  • You must be logged on to the PC as an administrator to install this update.
  • HLDS GWA-4162B 16X DVD(+/-)R/RW DL Drive.
  • Blank floppy diskette or blank CD-R disc.

ftp://ftp.hp.com/pub/softlib/software5/COL11049/pv-32087-1/SP26539.exe


#6

I am sorry, I wasn’t clear and did not specify that I already downloaded, burned and tried to run this update. The issue is the one that I initially specified and also read the other errors I specified afterwards. Thanks for the input, Los


#7

I posted the quote and link for people who are looking for GWA-4162B firmware. There must be many. I don’t have an HP PC that has LG OEM DVD writers inside and since it’s an OEM drive, one has to look for information and support from the relevant OEM company, not LG.

As for your question, aren’t you running Windows XP/2000? Why do you need DOS?


#8

The HP update here creates a boot floppy or boot CD with the firmware being flashed in DOS (FreeDOS)

Brother Vlad


#9

Ic. That’s why there were image files of such size.


#10

Same problem here. Just got an hp M1295c, and the hp site strongly suggests that I update the DVD burner. I followed the procedure above exactly, created a boot CD, and have the same error as posted by doubolplay1.

Has anyone found a way to successfully update this firmware?

Thanks,

Chris

Please e-mail suggestions to ccable@earthlink.net