Communication error with the LightScribe drive

It seems common but have not found a solutoin…

The problem in my case:

  • Samsung SH-W162L, FW TS02 as orginally shipped with the burner
  • Updated to LS host software version 1-4-105-1
    I wanted to burn a same lable on 2 DVDs. The data had alreay been burned on the DVDs. But after the 1st one finished (shown by the progression bar), the tray did not eject, or I did not wait enough time, I pushed the eject button on the device. Although I’ve got the lable on the 1st DVD, but when I burned the 2nd lable, this error prompted up:
    “Communication error has occurred with the LightScribe drive…”
    The process stopped.

Restart up Windows did not help.
I then upgraded the FW to TS03 downloaded from Samsung website, and updated the LS host software to 1-4-109-1. Both did not solve the problem.
Checked the IDE cable connection, no problem there; tried uninstall/install all Nero suit, still get the error. It seems to me the hardware had destroied somehow.

Before I go back to the shop, could anyone here give some suggestions?

I bought the thing in July, and had only burned 3 dvds with lables.

thanks!