Combo SOHC-5236K misflash - PLEASE HELP

I’ve tried to flash using bin modified with omnipatcher. I used MTKWinFLASH, and now Windows doesn’t recognise it.:doh: However, BIOS reads the drive fine, and a MTKWinFLASH also reads it, but it wont flash it with regular firmware.:sad: I also tried to flash it in pure DOS using MTKFlash (tried versions 1.55, 1.80 and 1.83c), but every time flashing stall at 00%. Can anyone here help me, it’s urgent? :bow:

How exactly do you boot up into REAL DOS?

Using win98 boot diskette.

Then delete or rename autoexec.bat and config.sys …

Check whether your drive is compatible with mtkflash.If mtkflash detects the chip you are luck.read the command line for mtkflash.Also you can try patched windows flashers for your drive

pejakm, this page may also help:
http://dhc014.rpc1.org/howto.htm

Also I don’t know if this applies to the 5236K but try holding the drive’s eject button when you reset your system, until the DOS prompt appears.

@C0deKing,
I have already read that, but thanks. I tried to hold the eject button, but nothing happened.

@shameer,
none of the patchers wont recognise the drive, except the MTKWinFlash.

Here’s the pic:


Strange thing, very strange.
The drive seems to work fine in DOS. When I load a CD or DVD I can access the data. I was able to copy some data to HDD, but when I boot to Windows, the drive is gone! I didn’t try, but I think I could even boot from CD (or DVD). So the drive is not dead afterall! Does anyone here knows what is the actual problem?

BTW, this is not my drive, but my cousin’s, I’m stayin’ at him few more days, so I need to fix this as soon as possible. Please help! :bow:

C’mon guys, can somebody help me?

I tried to flash the drive using XSF, but no luck. Any other suggestion?

Hi,

Get Knoppix, Kanotix or any other Live Linux. Burn that .ISO to CD and boot with this. You can also boot from another optical drive and then try if burning of CD is possible.
If both of these tests pass, then there is something wrong with that Windows installation.

BTW, this is not my drive, but my cousin’s, I’m stayin’ at him few more days, so I need to fix this as soon as possible. Please help! :bow:
Any possibility to try in another computer?

Michael

Hey guys!
I have managed to “repair” the drive.:slight_smile: Thank you mciahel, and all of you guys who stood next to me…:sad:

There was no problem at all. I took Windows installation disc and install the windows on third partition. The drive was fine! So the troublemaker was actualy the Windows. I simply reinstall the CD/DVD drivers of the Windows on main partition, and the drive was up and running!

I still can’t understand why I can’t flash it with firmware patched with “omnipatcher”. The LTNflash always stucks… I didn’t check the option to update the boot code. Is that it?

Anyway, I’m glad that I didn’t damaged the drive.

Thank you all once again!:bigsmile:

P.S. In the situations like this one it is really nice to be the member of such great forum like this one!