Cloning dvds-not working

I searched and couldn’t find the answer.

I’ve had this burner for a while…it burns audio cds fine and data dvds fine.
Lately, cloning dvds have been a problem. No errors pop up whatsoever.

However after the dvd is cloned, i go to check the data on it and there is nothing on it. So I try to do a test using “Nero CD-DVD Speed” and basically it doesn’t give me the typical pop-up…meaning that there is something on it or something has been done to the dvd and it’s no longer “unused” (the state it was before i put it in my computer).

I’ve tried to clone a few various other dvds…same results. Tried nice Verbatims…same result. Don’t know what’s the problem.

I’ve attached a jpg image of the results for the “blank…problematic DVD” (the destination disk…not the source disk). What else can I do to help you guys diagnose my burner’s problem?

What software are you using to “Clone” with. Might be that the disc was not finalized when written.

I assume that the DVD exhibits the same problem in other PC’s too. If it is finalized, then try the burner in another PC.