CloneCD doesn't remember Autoplay settings

vbimport

#1

If I set the Autoplay settings in CloneCD and click OK afterwards CloneCD doesn’t remember them. As soon as I get back into the settings Autoplay is disabled for Data and AudioCDs again.
Searching the forum for this topic is quite difficult because you get too many hits.
I’m using Windows XP with Service Pack 1.
I’ve already tried to uninstall / reinstall CloneCD and searched for registry entries regarding these two settings but didn’t find anything.
Thanks for help


#2

I just had a fiddle and my settings are saved each time.

I can’t help other than ask if your version is registered or not?


#3

yeah it is.
I tested this with my sister’s PC and she didn’t have any problems as well (Service Pack 1 and WinXP as well).
I also sent a mail to Elby because I believe it has something to do with the System’s Autoplay settings :confused:
Well it’s really strange.
I would really like to know which registry keys those settings are saved into.
BTW: System Autoplay works really good, only CloneCD doesn#T like to AUtoplay!
Hope someone else has an idea.


#4

Good news, I fixed the problem that CloneCD doesn’t remember the settings: With the help of my sister’s PC I found out which registry keys CloneCD uses to read / write those two settings.

Audio CDs:
HKEY_Local_Machine\Software\Classes\AudioCD\shell --> name: (Standard) (hope this is same in English OS) type: REG_SZ value: play

If this key is there in that form, CloneCD will be able to remember the Audio CD autoplay setting.
For the DATA CD setting the following key must be there:

HKEY_Current_User\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer --> name: NoDriveTypeAutoRun type: REG_Binary value: 95 00 00 00

Well that’s what I wanted to fix BUT (yes still a small “but”) as soon as CloneCD is opened, Autoplay won’t work anyway. It doesn’t work on my sister’s PC either.

Does it work for you guys?