CloneCd and Slysoft.com

I tried to download CloneCD from Slysoft (I want to update my purchased copy)
but when I click on download for the setup file it takes forever (I have broadband) and then it says:
“The document is empty”

Is Slysoft having problems with there site or is it Firefox (ver. 1.06) :confused:

I just tried to access the Slysoft web site without success, using both IE and Firefox.

“The document contains no data”.

Maybe they are updating the site.

works fine here

Hi :slight_smile:
Interesting I’ve tried, get D/L page but only when I try to D/L do I get a problem ie: no action/d/l
This is with both I.E. & FF.

Delete you temporary internet files, cookies, and cache, and try again.

Hi :slight_smile:
If you want to pm me your email, I’ll send it to you.

Hi :slight_smile:
I’ve done that & no different.

if you refered to me , alredy did and its still working

Hi :slight_smile:
For anyone who’s interested the problem no longer exists.
Update of site.
Everything OK now.

This happen to me before…
http://club.cdfreaks.com/showthread.php?t=157575