Clone DVD does not continue after selecting prefs

vbimport

#1

Hey,
I just need someones opinion on this situation:

Background:
I have been installing and trying out various combinations of software in an attempt to find the best (quick and easy) way to back up my DVD movies to 2 DVD. I have tried using CloneDVD, DVD Decrypter, DVDShrink and DVDFab etc. All of which are still installed on my PC except for DVDXCopy, which I deleted since I read it was junk anyway.

Goal:
I am trying to back up my movies while preserving the video and audio quality as well as the menu’s etc, while fitting the backups onto 2 DVD’s so that I get the best backups without compression.

Problem:
After installing CloneDVD 3 trial, I get to the first window after the program loads. I select the source (DVD drive or directory) and the Target (I tried DVD and also Hard Disk Folder/Directory), then I select the Copy Mode (Whole Disk). After doing so and clicking Next, CloneDVD just closes. Nothing happens after that. It just closes. Any idea on why this is happening?

And, what is the best way to achieve the goal of backing up without losing menus etc while preserving video and audio quality?

Thanks!


#2

clonedvd 3 is NOT the clone dvd for this forum


#3

saccorator wrote:

DVDXCopy, which I deleted since I read it was junk anyway.

Problem:
After installing CloneDVD 3

Get rid of it, it’s over priced junk, you should use Clonedvd 2 from Elby, The original Creator of the Clone Products