Civilization III & LiteOn 24102b

Hi, I’m trying to backup Civilization III on my LiteOn 24102b firmware 5S57, but when I finished reading the CD, mount it in Daemon Tools and start the game, it tells me to insert the CD…

I’m using CloneCD and Daemon Tools 3.02. I’ve tried the Game Profile, the SD2 AWS profile and the SD2 standard profile. My copy of Civ3 is the English version (ive heard the German version uses Laserlock). Any help would be appreciated!

Do you have “Hide CDR Media” turned on? You need to have that on when you run Civ 3.

Apologies if you have already done this, but it’s worth mentioning. Civ 3 was not that difficult to copy.

Chris P.

I tried using Hide CDR Media, but it still wants me to insert the CD. BTW if i’m using an image + Daemon Tools, why should I need Hide CDR?

You don’t need to hide the media when you’re trying to mount an image file. If I were you I’d first try to upgrade to the latest DAEMON Tools version because it could just be that DAEMON Tools was blacklisted with your game. An upgrade would probably fix this:

NB: I don’t use DAEMON Tools so I don’t know for sure if above is the case!

My recollection is that civ3 is hotwired to only run from the drive from which it was installed.

Originally posted by philamber
My recollection is that civ3 is hotwired to only run from the drive from which it was installed.

They fixed that in the first patch, IIRC.

And I’ll try upgrading Daemon Tools. I only experienced blacklisting once, when I was wondering why Emperor: Battle for Dune wouldn’t run (legal version). I ended up reinstalling the game and all, before I heard about blacklisting…:stuck_out_tongue:

No, upgrading to the latest Daemon Tools (3.23) doesn’t help. It still asks me for a CD…

I suppose burning to CD and try that way makes no difference?

If your game only plays from the drive it was installed from, goto the registry editor, HKEY_LOCAL_MACHINE\Software and find the game folder and look to see if it says something like:

CD Drive: D:
Installed From: D:\

Maybe if that is the case, adjust the D:\ to whatever letter your DAEMON Tools drive is.

O, I would also like to add that you should try changing the drive parameters on DAEMON Tools, I think its Generic Stealth DVD, try changing it to something else, worked for me with other games.

Thanks, the registry tip worked!

According to the 1.17 patch changelog, they did fix it, btw:

Additions v1.17f:

The procedure for checking if the CD is in the drive has been changed to search all possible CD drives on a machine instead of simply the drive they installed the game from.[/b]

Anyway, I’ll burn it to CD now. Thnx for the help everyone!

Just borrowed my niece’s CIV3. I already made a backup for her but I didn’t save the image. Produced a new image and it works fine in Daemon Tools (ver. 3.11), no emulation. CIV3 does care which drive was use for installation. I installed and played from the same “Stealth” drive. I installed an CIV3 update (older 1.16f) and it work too.