Changing DMA Mode in WinXP?

Hi Guys,

New to the board. Tried doing a search but didn’t find an answer.
I’m running Win XP Professional and just ordered the Plextor 24/10/40 which should be arriving soon. I have attempted to locate where Win XP displays the DMA mode for the CDRW drive. Currently I have a Richoh 4 speed ( don’t laugh it works fine, just slow) and I am unable to find how to check and change the DMA…
The bios is set to auto and when I look, the PIO mode is 4 and the DMA disabled. I then enable the DMA (in the auto mode) and boot. When I reboot I enter the bios and give it a look and the DMA is once again disabled. I don’t know if this is the way it should be since I ran this Richoh burner in Win ME with the DMA enabled in the device manager and worked fine, so it is capable of running in DMA Mode 2. Is it XP changing my bios back to disabled?
I have little knowledge of what the DMA and PIO functions are, but I do know Plextor says DMA should be enabled. Can’t enable what I can’t find. Any suggestions or advice are sincerely appreciated.

itz - I use the “classic” settings in XP, but you want to end up in the same place.

Go to Control Panel, System, Device Manager. Then go to IDE ATI/ATAPI controllers, and the properties of whichever IDE channel your writer is connected to (Primary or Secondary). In fact, go to all of them and select DMA if available.

That should do it. It worked on mine.

Thanks for the suggestion but it doesn’t list there. I hav done some serious browsing on this board and I may have hit on the problem but no solution was provided. I have a Asus P4B M\B and a P4 1.6 mgh processor. With the M/B came a disc and instructed to add the intel drivers along with a program called Intel Applications Accelerator. I think between these two programs and has disabled the feature to select the DMA.
I find it strange when I go into the Intel Acclerator program it lists all the configuartions of all drives but one cannot change anything, this is just a reporting tool.

Under the CDRW (master on secondary ide) it indicates the following:
UDMA Support-No Support
Current Tranfer Mode-DMA MW-2

Under my CD unit (slave on secondary ide) indicates
UDMA Support 0-1-2
Current Transfer Mode-UDMA-2

What this indicates to me the CD is capable of Ultra DMA mode
but the CDRW is not supported.

Confusinfg the hell out of me, I have searched everywhere even unfer Computer Management/Disk Management but nothing there.
Tried all the contollers in Device Manager as well as the properties in DVD/CD Roms but nothing there.

…a program called Intel Applications Accelerator. I think between these two programs and has disabled the feature to select the DMA.
Correct. If a device is capable of DMA then it will be enabled - don’t worry about it. The Intel driver removes the DMA check box in Device Manager. Not sure what happens in the DM in XP because I have not tested this Intel driver in XP yet.

As for the BIOS thing, XP cannot change anything in the BIOS because everyting enumerates before XP can do it’s stuff. I would suspect a faulty MoBo; enabling UDMA in the BIOS is critical.

Future Proof

Thanks for the reply. I have double checked the bios 3 times now with the same results, it always changes the UDMA mode to disabled. I am confused since this is the master on the secondary ide and the CD rom is the slave.
The CD Rom indicates UDMA is enabled. Both are set to automatic and when I change the setting to manual and select UDMA 2 for the CDRW, it holds the setting.
I don’t believe there is anything wrong with the MB since it would not enable the UDMA for the CD Rom if it wasn’t operating correctly. Perhaps there is something wrong with the Ricoh CDRW drive and not permitting it to enable UDMA in the auto mode.

The true test will be when I receive the new Plextor 24/10/40

I did order a 80 pin cable with it to maximize performance, if I get the same results with the Plextor I’ll try the cable select mode on both the CD Rom and the Plextor to see if this changes anything.

If that doesn’t work I may just uninstall the Intel Application Accelerator and see if the option to select DMA appears.
Computers can drive a man to drink.

i have the asus P4T
and have no problems but did not install any intel software

and on my plex writer i get

multi-read dma mode 2

hope it helps
time to remove that software i think

It’s not the Asus P4B Motherboard, nor do I believe it’s the Intel software. I think there is something wrong with the Richoh CDRW that’s in there now.
I installed the 80 pin cable tonight and it still read disabled. I then moved the Richoh to the slave position and the CD Rom as the master. Once again the CDROM indicated UDMA enabled and the Richoh disabled. It has to be the drive itself.
The Plextor will be arriving Monday and I’m certain this will read enabled when I install.
As mentioned the Intel Application Accelerator seems only to be a reporting tool and merely indicates what the bios is set at.
The bios is indicating the Ricoh is not capable of running in the UDMA mode when set to auto.

I do have a question for you on your P4T MB. Did you try to activate the Post Speech Reporter? I had loaded the default sounds but it never has worked. I really don’t care since this is merely another whistle I can do without. But I am curious if others are using the feature.

Not to worry. :wink:

Originally posted by itzbinnice
Under the CDRW (master on secondary ide) it indicates the following:
UDMA Support-No Support
Current Tranfer Mode-DMA MW-2

Your burner is running as its maximum specification capability at DMA Multiword 2, which has a transfer rate of 16.7 MB/sec. This is a true DMA mode, and provides far more throughput than your burner will ever need. Burning at 4x only requires 600 KB/sec, and reading at 20x just 3 MB/sec.

Ultra DMA Mode 2 has a maximum transfer rate of 33.3 MB/sec, which is the mode for your CD-ROM. You didn’t mention the speed of the CD-ROM, but a 56x has a maximum throughput of 8.4 MB/sec.

The only (theoretical) value of the modes with bandwidth far in excess of the throughput capability of the device is to allow a buffer burst. RAM contents in a buffer can be “dumped” without the mechanical limitations of the normal data transfer. This just means that the contents in a RAM buffer in a burner, CD-ROM, or hard drive can be instantly fed through the ATA interface up to the maxiumum speed of their DMA mode. In practical terms, this just takes a fraction of a second and probably wouldn’t even be noticed. The RAM buffers in CD-ROMs are very small, so any “buffer burst” would be a non-event.

The true value of the DMA mode for burners is not so much the speed (PIO Mode 4 has the same transfer rate as DMA Multiword 2). The value is in the multithreaded direct access to memory without having to use the CPU for access. This reduces CPU utilization significantly, which allows a device to perform at its maximum capability.


Damn, you sound like a genius when it comes to burners.
Here I went ahead and un-installed the Intel Application Accelerator and it didn’t change a thing. Didn’t see any slow down in performance, so I guess I’ll just leave it off, Win XP has enough shit to confuse me.
BTW the CD Rom is a 56 speed. You have just put my mind at ease just in case the Plextor 24/10/40, which arrives tomorrow,
also may display PIO 4.
I would have spent hours trying to figure out what is wrong.
My sincere appreciation for your time, it is sincerely appreciated.

Just to let you know, I pasted one of your posts to a reply for someone who was having a problem with Roxio & Nero.
I did state it was pasted from another poster, hope you don’t mind.

Thanks for the kind words. I’m glad to be of service. :slight_smile:

No, I don’t mind at all if you used one of my posts to help someone else. If it is copied and pasted, the usual protocol is to give credit to the originator by name. Usually it’s a good idea to provide a link, so that the reader can see the context of the quoted material.


My apologies for not using your name, since you deserve all the credit. As for pasting the link, I was reluctant to do so, some sites
don’t permit pasting links and quite frankly I was too lazy to read the rules of this board.


No apology necessary. But thanks for the consideration.:wink:

Well guys got the Plextor 24/10/40A today and installed without a hitch. The DMA now registers at 2 and everything works fine. Installed the Nero software (without packet writing) and the Roxio Platinum and Nero are best of friends, no problems.
I was very impressed with the Plextor packaging, and comprehensive manuals.
I thought for sure my old Ricoh 4 speed was defective since it would not be recognized as DMA capable, neither in Win XP or Win ME on my new computer.
Well I stick it into my old computer which has a Pentium II 400 mgh and running Win ME, guess what, it displays DMA 2 enabled.
Go figure, I’m going to give that unit to my nephew and I feel better knowing it will cause him no problems.

For some strange reason, many IDE burners do not have UDMA modes detected correctly by the bios. However, window detects that it is dma capable, even if the bios does not, and they seem to work okay windows.


“I find it strange when I go into the Intel Acclerator program it lists all the configuartions of all drives but one cannot change anything, this is just a reporting tool”.

But Intel Application Accelerator does have settings you can adjust. Highlight the drive in the left pane, then double click Transfer mode limit (with the wrench) on the right pane and you can set the limit. You can also set Auto-Acoustic Management on the HDD if available. IAA increased my HDD performance by at least 10%. After installing WinXP with NTFS my HDD slowed down over 30% from the speed I had with WinMe, so it helped.

Dell Dimension 8200 (i850)
P4 2GHz
512 MB PC800 RDRAM
(2) 80 GB Maxtor DiamondMax Plus 9 (6L080L4)
NEC ND-1100 DVD+ burner
LG GCE 8400B CD-RW burner

Now if I can only find something to change my HDD to UDMA 6, they only run at 5 but are capable of 6 (ATA133).

You can’t change the speed of the drives to ata133 unless
the clock rate on the IDE controllers is increased 33% or they are already ATA133 compat, and just need a registry hack to supoort it.