CDRW read problem

vbimport

#1

HI,

I 've discovered my read problem has something to do with the software.
Please let me know how to fix this.


-- Something interesting:
I installed the Acer CDROM driver on MS-DOS. Using MSDOS read a file from the cdrw media - perfect - File compare said they compare exactly.

Booted to Win95 - Every new read gives a different set of mismatches. (Both with the MSDOS driver installed and with it commented out).

I would like to be able to read using Win95. I tried the ASPI fix, (used ASPICHK.exe and ASPI_ME.exe). ASPICHK said there was a problem, I ran ASPI_ME, then rebooted and ran ASPICHK again - it said everything was OK, but the same problem with the files I read from the CDRW media occurred.

I am not sure how ASPI_ME.exe works, I had to change the system date to 1998 to get it to run.
Please let me have your comments.

===============
Here is my original post to the Newbie forum:
===============

My Acer 2010A came with Prassi Primo software. I use it with a win95 osr2 system and sometimes with a win NT (sp6) system.
(I use the same drive on two systems)

When I do my copying on the win95 system with cd-r media, everything works fine.

I burnt a cdrw disc on the win NT system and can read it on the CDROM drive (LiteOn/IBM) perfectly fine. I took the cdrw to my win95 system and read it with the Acer 2010A, (the old Creative CDROM - infra36 cannot read the cdrw media), there are lots of glitches on the mp3 files on the cdrw media. (No problem reading them on the NT system).

On the NT system the 2010A is the slave, while on the win95 system the drive is used as the master as recommended.

Can some one point me to the cause of the problem and the solution?
Many thanks,
xs400


#2

Perhaps a new firmware would solve some things.

It seems there’s just a timing problem when reading/buffering/writing the files and controlling the transfers.

You could set the drive’s properties on to synchronous to make it more reliable.

I’d also suggest upgrading your motherboard drivers in the Operating Systems.

NT has a different approach of reading the various devices in your computer than the 9X series which are far more dependent on the drivers that were provided. Some proof of this can be that it works under Ms-Dos , which uses the old MSCDEX method.


#3

Hi !

Thanks for the replies. I had used a slightly longer cable (IDE), either the cable was bad or too long. Going back to the old cable seems to have fixed the problem. Have to test it some more to be sure.

Thanks,
xs400