CDRW/DVD drive not working with new comp

vbimport

#1

I’ll try to make this quick. I just assembled a new computer with the following parts:

-MSI K8N Neo4-F Motherboard
-AMD64 3200+ Venice
-Kingston ValueRAM 512x2 PC3200
-MSI nVidia 6600GT PCIe
-Antec TruePower 430
-Hitatchi 7200rpm Deskstar 200GB (IDE1/Master)
-Samsung SM332-B (IDE1/Slave) DVD/CDRW Combo
-WinXP Pro/SP2

The problem is, it doesn’t seem to like my optical drive. I pulled this combo drive from an older machine and it was working fine on that, so I don’t think it’s the drive itself. When I originally plugged it in, I had it on IDE2/Master. It installed Windows fine, and I was able to update some drivers with it (not the SW IDE). But after a power down and turn on, inserting a CD would produce the following error:

MACHINE_CHECK_EXCEPTION

STOP 0x0000009c (0c00000004, 0x80545FF0, 0xB2000000, 0X00070F0F)

Because everything else is working fine, and it only occurs when I stick a CD in, I’m assuming it’s the CD drive causing the errors. So I moved the drive to IDE2/Slave and it works. Kind of. It can read and write CDs, but it can’t read DVDs. I’ll stick a DVD in and nothing will happen. The light blinks, it spins, and nothing. Windows and other programs don’t recognize there’s a disk in there. I also tried putting an entirely different CDRW drive on IDE2/Master, and that worked, but it made Windows take an extra 30 seconds to boot. I’m not sure if the IDE2 port is toast or what.

So it’s been recommended that I replace my drive. I’ve been looking around and I have a couple of options. First, to go with a Plextor SATA drive (712SA) and bypass the IDE port altogether, and second to just try a newer drive (NEC 3520). I looked at the MSI website and it lists the Plextor 712SA as tested and compatible for my MB, and there are also some older model NECs listed, but not the 3520.

Any ideas for what I should do? Do I really need another drive? Does anyone have this board and know a specific model that works? I’m trying to avoid ordering a new drive only to have the same problems. Any advice is most appriciated, and sorry if this is the wrong forum to post in.


#2

Are you positive that your drives are jumpered correctly as master/slave, and that they are in the correct position on the ide cables.


#3

Yep. I checked multiple times and made sure the cable was plugged in nice and tight. I should also mention that the BIOS and Windows both detect the drives fine no matter what position they’re installed in (even IDE2/Master).


#4

Two things

  1. There is a firmware update available which is worth a try:-
    http://product.samsung.com/cgi-bin/nabc/support/b2c_downloadcenter_detail.jsp?eUser=&mobile=N&oid=55523&cntType=FM&cntId=39997&lang=ST

  2. You MB will support whatever DVD writer you decide to buy, regardless of what MSI state.

If you want to burn DVDs then get a DVD writer as the Samsung is only a reader (if it would actually read).


#5

see this regarding the error message : http://support.microsoft.com/?kbid=329284

check your ram using memtest86+ : http://www.memtest.org/download/1.60/memtest86+-1.60.iso.zip (burn it with nero as image)

is your cpu overclocked? that might be another reason
it may be unstable if so undo the overclock and see if it helps
and if you are into overclocking its no good if not stable so
when you overclock check with memtest86+/prime95 for stability

check your cpu temperature/psu voltages,with speedfan
http://www.almico.com/speedfan.php
take a screenshot and upload to http://www.imageshack.us and give a link
so ill see if they are at normal levels

there are several possible reasons for ram errors:

a) overclock ,when doing overclock ram speed goes up aswell as the cpu
so the ram may reach its limit or at least limit along with the current voltage

b) bios incompatbility with that specific ram,bios updating will resolve that
check bios version history on your motherboard manufacturer site to see if thats the case

c) ram timings too low for its current timings ,set em higher but its better to use spd,if ram timing is set to spd bios will read & use the default manufacturer suggested timings from the ram module,of course recheck with memtest after each change

d) ram voltage defined too low , put it higher every time a bit more and recheck with memtest after each change,upto 2.8V is just fine above that it might toast it at least if your ram aint supporting a higher voltage

e) 3.3v rail too low

f) motherboard incompatbility,you can see with what kingston ram your motherboard was tested with on the folowing site:
http://www.kingston.com/products/default.asp

g) ram plain bad but that isnt very common

edit : forgot to mention ,memtest runs all the time until you reboot
i suggest youll give it at least 7 passes , also i havnt mentioned it because its obvious but just incase it isnt. you should configure the bios to boot from cd


#6

Thanks for all the help so far guys. I’m at work right now so I’ll have to wait until I’m home to try these things. But I can tell you that nothing is overclocked. Everything is at stock. I also had the mobo/processor tested before it was shipped out to me.

The only reason I want to try one listed on the MSI site is so I can have a little more assurance that it will work. I’d have thought just about any drive would have worked, but I guess sometimes there are things like this that can’t be predicted.

I did have to tweak the BIOS to make sure the RAM was running at 2.6v, though. But that’s what the specs call for. It’s also listed as compatible on the MSI website. I also don’t have a pressing need for a DVD burner, but since it looks like I have to buy a new drive I may as well get one (and a good, reliable one at that).

edit: I am thinking of stopping off at Staples on the way home to pick up any 'ol DVDRW drive just to test what happens, then return it. Or is that unethical? :confused:


#7

OK, I ran SpeedFan and Memtest86. Memtest went through 7 passes and ran for almost 3 hours. Here is the screenshot from SpeedFan. Does everything look okay? I’m assuming because Memtest didn’t crash that the memory is fine.

Here’s the cap:

Fan 3 must be the chipset fan, and I’m going to guess that Fan 2 is the CPU fan. I don’t have my two case fans or my PSU fan plugged into a sensor, but I’m sure they’re fine. I didn’t get a chance to stop at Staples after work today, but tomorrow I’m going to try whatever drive I can get my hands on and see what happens.


#8

voltages & temperature looks fine,regarding memtest your wrong it doesnt mean nothing regarding the ram condition you should look under the “errors” tab and also supposaly faulty ram addresses will be displayed down like in this screenshot http://pjarillon.free.fr/docs/memtest-pey.jpg but in a red background
i woudnt be so hurry to get a new drive if i were you. look at the reasons described in the microsoft link i gaved out in my previous reply i guess it somewhat possible its the drives fault but there could be several other reasons aswell,update the bios it might help,also i suggest youll test system stability with prime95 http://mersenne.org/freesoft.htm and run speedfan while your doin it to monitor the temperature/voltages


#9

phil,

I did go through that link you brought up. That was actually one of the first things I found when I put the error into Google. That’s also how I learned to remove the nVidia SWIDE drivers. The one thing that really struck me was “Vendor-specific detected hardware problems” could cause this error.

In regards to Memtest, I didn’t get anything that looked like that. That’s basically what I meant. It didn’t throw up any errors, it just kept going for almost three hours without anything changing. I’ll hammer it with prime95 tonight and see if that does anything.

I’m not so sure the BIOS would fix anything. I’ve been told that unless your issue is specifically addressed in the update that it’s not worth the risk of misflashing. That said, I have v1.4, but there is a 1.5 and it lists these changes:

This BIOS fixes the following problem of the previous version:

  • Update CPUID.
  • Update NVMM version to 4.052.08.
  • Update NVPXE version 2.12.

I don’t know what any of that means, but is it relevent to the problem at hand? I’ll check to make sure I have the latest chipset drivers installed too. Although I originally got this error message after installing the latest nForce drivers from nVidia’s website, so I don’t think it’ll help any (without SW IDE). How long do you think I should run Prime95? And to be clear, we’re talking the Torture Test, right? I’ve never really used this program before so I’m uncertain what to do.

I sincerely appreciate all help so far though. Thanks! :slight_smile:


#10

according to the bios version history i dont think it will help,
regarding the chipset driver did you installed the unified one or the nforce4 specific one? if not the nforce4 specific one then grab it from http://www.nvidia.com/object/nforce_nf4_winxp2k_6.53 and if you did got the nforce4 one then try the older version http://www.nvidia.com/object/nforce_nf4_winxp_6.39 and dont forget to uninstall the current one before ,
regarding prime95 well the homepage recommends 24hrs but thats just too much i think 4/5 hours will be just fine and yes the regarding the test , it’s nice to be appreciated :smiley:


#11

Looks to me like a memory/RAM problem.
Remove 1 of the two ram sticks and try again.


#12

if you would have read previous reply’s you would have know i alredy suggested that and that the ram was tested and is in good condition :doh:


#13

I did the nForce4 specific ones before, but I tried them again. No luck. I installed the 6.39 drivers first, then the 6.53 (both without SW IDE) and nothing helped. Before I fire up Prime95 for the night, I thought I’d post this and see if it’s normal:

Does that look right? Are there supposed to be three of each listed? I sorta thought there should only be one Primary, one Secondary, and one Controller. And this has me thinking. Is there anywhere else besides Device Manager I should be looking for conflicts? I don’t notice anything here, but should I look elsewhere? Are there any BIOS settings for IDE devices I should be checking? I’ll report back with my Prime95 results probably later tonight, maybe tomorrow morning. Thanks again for the continued help.


#14

Delete (uninstall) all of the IDE controllers and then reboot.


#15

Just the Standard Duel Channel PCI Controllers, or everything in the IDE ATA/ATAPI controllers category?


#16

Same thing. Just uninstall the “dual channel IDE controllers” and reboot.


#17

Uninstall the dual-channel controllers, the individual channels are sub-devices that’ll be automatically uninstalled along with their parent device.


#18

im not so sure removing em will sort it out,you might wanna consider installing nvidia ide driver :rolleyes:


#19

OK, I’m still at a loss. I tried a couple things. First, I ran Prime95 for four hours and it didn’t report any errors or warnings. SpeedFan didn’t report any temps or voltages out of the norm. I also tried uninstalling the controllers and rebooting. It didn’t help. Windows redetected them on startup, and everything is back. I tried setting all idle IDE from “Auto” to “None” in BIOS, and that also didn’t do anything. Are these “extra” controllers SATA controllers? Would those be listed in this category? I don’t know why else there would be more than one primary and/or secondary IDE channel. Maybe someone can help answer that one. Would disabling two of them help? I was able to uninstall the bottom two without needing a reboot, so I’m guessing those are the ones without my HD/optical drive on them.

Anyway, I’ve done everything suggested and the thing still doesn’t read DVDs. Any other ideas? I don’t know that installing the SW IDE drivers will do anything since I did that the first time I installed Windows and that’s what I first thought the problem was. If you all think that will help, I don’t have much to lose by trying. But for now, I need to get some sleep. More thanks for continuing to help, even though nothing has worked yet. :frowning:


#20

i think the reason you have that many ide channels in device manager is driver related,install nvidia ide driver

did you do what timc suggested? (updating the combo drive firmware)