Cdrw drive has disappeared!

vbimport

#1

hi all.

i don’t know if this is the sort of quesion i can ask here, but i can’t think of anything else to do after searching the internet for the solution for hours now. seeing as all you guys and gals helped me out so much with my burning vcds problems, i thought i’d ask. if it’s an innapropriate question for this forum/site, i sincerely apologise.

after reading through chickenmas tutorials, and a lot of help from this thread, i have been a vcd burning maniac for the last few of weeks. i turn my computer on this morning, and my cdrw drive has disappeared. it’s not on my computer or device manager. there are no ‘unknown devices’ on device manager. i did a system restore to a couple of weeks ago, and still there’s nothing. the last thig i installed was winamp and virtualdub a when i started burning vcd’s 2 or 3 weeks ago and things have been fine till this morning. someone has said it is usually caused by a media player or burning program? has anyone else ever had this happen to them and if so what did you do?

i will be eternally grateful for any help on this matter and thank you in advance to anyone who can help.

eli


#2

Is the drive detected during POST, and if so is it functional in DOS?


#3

It may be work checking if windows has lost the secondary IDE controller. A while back, I had both the CD-ROM and CD-RW drive disappear out of the blue with the same problem.

To check your IDE conenction status, go into your device maanger. Open the section ‘IDE ATA/ATAPI controllers’. Make sure there is at least one primary and secondary channel. If there are two primary chanells (for two IDE controller’s onbaord), make sure there are two matching secondary channels. If so, go into the IDE channel’s properties for the channel your CD-RW drive is on. Normally the CD-RW is on the secondary channel. Click the ‘Advanced Settings’ and make sure both sections ‘Current Transfer Mode’ settings are set to ‘DMA if available’.

If the above doesn’t work, another thing that worked for me, particularily if Windows XP gets stuck in PIO mode on a particular device is to uninstall the IDE channel your CD-RW drive is on and reboot the computer. When Windows redects the IDE channel, it tends to pickup the correct settings for the drive also.

If one channel is missing (happened commonly in Windows 98se on me), uninstall the BUS master for the channel that’s missing and reboot the computer. Have the IDE driver disk handy if you do this.


#4

rdgrimes to be perfectly honest, i am only a basic computer user and i don’t really know what you mean about POST, sorry, and have no idea how to check DOS
:o

seanbyrne i tried what you said, (although i didn’t know how to uninstall the BUS master because i don’t know what channel is missing, and all my driver discs are on cd which i can’t use) and it’s still not there.

i’m really sorry, i know how annoying it can be to try and help out people with basic skills, but honestly, i’m trying to better my knowledge! :wink: so thanks for the input.

eli


#5

Put your windows install CD in the drive and reboot. If it tries to boot to the drive, then you know it works at least that much. Also look for the drive light to flash on startup.
POST = power on self test = all the black and white stuff that flashes on the screen when you turn the system on. It will list all the drives that are detected.

If all that checks out OK, then go to device manager and open the entry for the IDE controller. Right click on the secondary channel and select uninstall, then reboot. You can also uninstall the primary channel, no problem, you are just forcing Windows to re-detect and reinstall the controllers.


#6

i don’t have a windows install cd, it is a system restore cd, but i put that in and nothing. the drive lights do flash when i insert a disc. i’m using windows xp, and you don’t get the black screen with the white writing on startup, just a ‘loading windows xp’ sign so i don’t know how to check the POST thing. i have uninstalled both of my IDE channels (secondary and primary) then rebooted my system but nothing. i really have no idea what else to do now, other than format my c drive and start again, which is something i really don’t want to do because i have around 30g of files which i know is my own fault, i should have backed up earlier.

thanks for all the help, and thanks for any more you or anyone else can offer :slight_smile:

eli


#7

Find a bootable CD and be sure that the drive does not boot, cause if it doesn’t, it’s a dead drive. This assumes that your system is set to boot from CD. Or boot to a Win98 floppy and try to access a program disc in the drive.


#8

Originally posted by rdgrimes
Find a bootable CD and be sure that the drive does not boot, cause if it doesn’t, it’s a dead drive. This assumes that your system is set to boot from CD. Or boot to a Win98 floppy and try to access a program disc in the drive.

i cannot agree with rdgtimes on this one.just because the cd doesnt boot or not is no indication that the drive is dead.

what cause this problem is usually having a 250 watt power bundle on the system may need more like 300 watt .amd always needs 300 watt if you have one.

this problem doesnt even take 2 minutes to fix
here are the steps!
1)goto the device manager
2)remove all cdrom drives from device manager
3)reboot (it will now search for devices)
(dont fret if all cdroms dont show up)
4)now power down for a least 1 minute
(remember the power bundle problem)
5)drives will now appear
6)if successful and only have a 250 watt power bundle go get at least a 300 watt

good luck

if only have a 250 watt power bundle and have many device attached to your computer
can also create this problem!:bigsmile:


#9

If it won’t work in DOS, then you’ve eliminated Windows and all burning software as a source of the problem.
Another simple test is to insert any disc and listen to see if the drive spins up during boot. If not, it’s very likely a dead drive. (If it’s set in BIOS to boot, it will always spin up a disc when booting.)


#10

thanks once again for the suggestions.

2nd sign, i tried what you said, even left the computer off for an hour but still nothing.

rdgrimes, when i am inserting a disc the drive lights are coming on but i can’t hear it spinning.

i got to the point where i was ready to throw it out of the window, so i phoned up the supplier of my pc, they ran through some checks, they are ending me a new drive out. seems they have encountered a few problems with the combi drives on my model. i suppose the good thing is i am getting seperate drives as a replacement (rather than a combi one) although i’m going to be without for about a week because they are out of stock.

thanks a million for all your help (as always).

eli