CDFreaks Presents: The Plextor PX-755A DVD Burner Review

CDFreaks Presents: The Plextor PX-755A DVD Burner Review


You can read the review here

Please feel free to comment on the review in this thread.

Hi :slight_smile:
Thanks Dee, excellent stuff. :clap: :cool: :clap:

Thanks Dee.
Good review as always.

[B]Thanks for the good job ![/B]

Usualy there is a photo of the burner’s board in the reviews.
So this time I miss such a photo and explanations about this “strange wiring”

Nice work! Thanks!

Wow, Impressive Review. Very, VERY dissapointed with the sheep test :frowning:

How about: http://club.cdfreaks.com/showpost.php?p=1301857&postcount=44 ?

In this “full” review I miss also:

1°) Tests about the [B]practical effect [/B] of the new AustoStrategy on selected MID codes.
About this new AS they just reported what Plextor published on their site and used the “Auto Selection Mode” for every MID code without doing any “Forced Mode” burn.
YSS published a lot of such tests but only in japanese …
http://homepage2.nifty.com/yss/px755a/px755a_dvd8x1.htm
http://homepage2.nifty.com/yss/px755a/px755a_dvd8x3.htm

http://homepage2.nifty.com/yss/px755a/px755a_dvd4x.htm
http://homepage2.nifty.com/yss/px755a/px755a_dvd8x2.htm
http://homepage2.nifty.com/yss/px755a/px755a_dvd8x4.htm

2°) Again [B]no extensive TA tests [/B] and related comments on compatibility with standalone DVD players.

When burning the media for the review, we used the method we perceived most users would use when using the drive in everyday use.

Adding TA tests would have made this review non-consistent with our other reviews. We feel having consistent reviews is more important to our readers, so they can easily compare one drive with another.

Regarding “stand alone compatibility” All the single layer media was data disc’s. :slight_smile:
The tested DL media which was burned with “video content” does include a standalone compatibility table.

Thanks Dee for your clear answer !

Hi. I’m new to the forum, and I appologise if this post is in the wrong place, but I tried to append it to the review page itself but it kept telling me to “Please Login” and having done so 3 times I wasn’t allowed an opportunity to actually create a post.

Firstly let me say that the review itself was excellent - thank you - and was very instrumental in my decision to purchase this drive. HOWEVER.

I have been mega disappointed with this drive and although it cost me £70.00 I am thinking of ditching it - but I thought I would try here first in case I have a touch of DBS - and there may be some help available from all you nice people.

As there is only one set-top DVD player where I live, and the taste in DVD’s of the people here are at different ends of the spectrum, I am forced to watch mine on my computer. (I don’t mind as I’m the only one here that can use a computer anyway)
So apart from burning a few personal mp3 cd’s the main use of my Plextor is to allow me to watch DVD’s on my computer. But for some reason, this drive for the most part refuses to read any pressed dvd disk. All the DVD’s I watch are either hired or bought for me, so they are all genuine pressed DVD’s and as your review says the drive can read DVD-VIDEO I can’t understand why I have this problem.

When I say refuses to read the disk I mean either in Windows Explorer (XP Home Edition SP2) - where it instead of reading the contents of the disk it just hangs, with the cursor arrow changing to a cd icon every few seconds as it tries to read the disk, but never gets there. Or from Windows Media Player or PowerDVD where it attempts to read the disk and either hangs indefinately or reports No Disk In Drive. I have updated the firmware to version 1.02 from the plextor site with no difference made, and scoured their FAQ for help and even changed the IDE driver from INTEL back to Microsoft, still with no improvement made. The annoying part is that it seems to read any other DVD or CD (even home burnt ones) properly without any problem and it seems to burn disks with no problem, but it just refuses to read most pressed DVD movie disks of which I have tried many. I say most because on two occassions it did read a pressed movie disk ok, but only twice and there was no difference in the drive or computer on those occasions.

I know I’ve gone on a bit too long with this thread and if that’s an offence against the forum I’m sorry but I couldn’t summarise it any shorter. Is there anything I can do to get this drive to read pressed DVD movies? Thank you.

Hi MeterMaid and welcome to the forum.

Here are some things you can check.

1, Check DMA is enabled on the IDE channels. You can do this by right clicking on “MY Computer” and navigating to “device manager”. Find the IDE controller and check that DMA is enabled on all channels,the correct setting for the Plextor should be UDMA mode 4.
2, Make sure you have no packet writing software installed.
3, Check that you have set the correct “region control”

If all this fails you may have a faulty drive. If this is the case, contact Plextor and they will arrange for your drive to be picked up and repaired or replaced free of charge.

Hi Dee - many thanx for your reply.

I have checked the things you mentioned :iagree: and found the UDMA was already correctly set, as was the region setting. Packet writing software - I don’t know. To burn my CD’s I use NTI DVD&CD Maker version 6, but I don’t use re-writable disks at all.

However, as you advised, I completed the online RMA request form on Plextor’s site and they have issued me an RMA number to return the drive for exchange. I wonder if they’ve had a batch of bad drives for some reason.

Anyway, thank you very much for your help and I’ll gladly recommend this forum.

Hi,

I too have got the problem with my Px-755a reading original Dvd discs.
Have checked my settings and everything is fine.

Guess it’s time to contact Plextor. :a

I had the 740 and it worked great. I had to get a replacement as I gave my 740 away. I’m using the 755SA and so far I have yet to convert a single avi file to a DVD without issue using nero vision which always worked well in the past (I’m using the latest version). Everyone so far has either a sync issue, speed issue or just general corruption in the media. My 740 never had these issues - I’m still trying to track down a solution, I’ve tried changing the recording speed, pass quality, updating the firmware, moving it to another SATA controller but haven’t found a solution yet.

I’m using top of the line verbatim DVDs - worked great with the 740 - so far I’m not thrilled with the 755sa.

I’ve uninstalled, ran the nero clean tool - rebooted and installed the latest nero download - getting this in my burn log although I had previously been able to burn this avi to dvd -
[20:09:25] DVDEngine ERROR
[20:09:25] DVDEngine cause: 128 (nmc_processing_exception)
[20:09:25] DVDEngine source: CDVDProcessor::ProcessSector
[20:09:25] DVDEngine description: buffer overflow

Please explain what solidburn is. I have 755SA and don’t see that option.

Nero reports my drive has that option, yet I don’t see it even with Plextools.

Solid burn is a BenQ term. Not sure where you saw this but Autostratagy is pretty much the same thing without going into a lot of detail.:wink: Both Solid burn and Auto stratagy create a new write stratagy if set to on, if set to off the burner will use the write stratagy from the firmware data base. Hope this helps.:slight_smile:

Thanks for clarifying crossg :slight_smile: I saw the info from Neroinfo tool (see picture attached), oops, I just found out I was reading the columns wrong. :confused: :o I was looking at the checkmark to the left of solidburn and labelflash. The info is always good to know though.