CDFreaks presents: The LG GSA-H62LI Super Multi DVD-Writer Mini-Review

CDFreaks presents: The LG GSA-H62LI Review

You can read the review here

Please feel free to comment on the review in this thread

Thanks Kip and good mini review :clap:

Thanks for the nice mini review, Kipper! :slight_smile:

:bow: Thanks for that nice review on the drive. :clap:

Welcome guys, and thank you

Thanks Kipper, another great review!

Can’t wait to see your next one! :slight_smile:

Personally I really like this drive. :slight_smile:

does all LG have this minor issue?

Reads pressed DVD-Video SL/DL media at 4.8x.

Great mini review Kip, keep up the great job your doing!

Nice mini review, but I’m curious about this:
[I]Quality issue when burning a sample of our Taiyo Yuden CD-R media which resulted in 400+ C2 errors.[/I]

Will future firmware fix that hopefully? I have a lot of TY CD-Rs I got from Kmart and would like to know if it was better to get another drive if all the H62s were like that. Thanks.

H42N and H62N have the same problem with Taiyo Yuden CD-R media.

If you plan to burn TY CD-R you will be better off with an LG drive based on a Panasonic chipset: H22N or H50N or [even] H55N.

P.S. I wish I had a dime for every time somebody mentioned a “future firmware fix.” :slight_smile:

I see, thank you. It’s like I’m doomed it seems, everytime it seems I’ve found the right drive for me, their is always something that pops up to prevent me from getting it. I can see why people own so many drives now :slight_smile:

Depends on what “a lot of TY CD-Rs” is; 20 being a lot to some and maybe 1000 being a lot to another.

This drive does a good job with most CDR and does a great job with most DVD media; I would say this drive is a keeper regardless of how it handles TY CDR discs.

thanks for the mini review…the verbs did good at 18x…looking forward to see how it does at 12x and 8x :slight_smile:

the kmart TY’s arent they fuji…and the burns done with fuji TY’s did very good in the mini review

I have over 500 and that is considered a lot to me, it may not be to others. I agree that its a nice drive, but if you were a one drive owner and had a lot of the type of media that this drive doesn’t burn well, it probably wouldn’t be a good idea to get it.

Yeah, I’m just now catching that, I guess I may not have to worry about it after all.

H42 hasn’t got an issue with TY CD-Rs, as far as I know (and I own one). It has got an issue with ALL brands of CD-Rs, but ONLY when burned at higher speeds (48x, 40x, 32x for sure, 24x still not certain). If you can live with burning your CDs @ 16x, it’s a great drive. Mind you, the drive does not make C2 errors every time it burns a CD at high speed, but it does so approximately 50% of the time. New firmware may or may not be able to fix it, so if you do mind burning CDs @16x - skip it.
As far as I know, the only difference between H42 and H62 is the interface (IDE-SATA), so H62 probably has got similar problem.

[QUOTE=Explicitez]I have over 500 and that is considered a lot to me, it may not be to others. I agree that its a nice drive, but if you were a one drive owner and had a lot of the type of media that this drive doesn’t burn well, it probably wouldn’t be a good idea to get it.

Point taken, 500 discs of one MID is a lot for most folks. I seldom burn CDR except for reviews and when I do I do burn them at a much slower speed and do find quality burns with the H42 and H62 as long as I am not trying to break speed records with it. It is after all a DVD burner and it does a sweat job with most DVD media.

Quote:
Reads pressed DVD-Video SL/DL media at 4.8x.

Any answers to this question?

not all LG. Just the Renesas drives. The Panasonic drives are rip locked at 8x speed ^^

I have a question. I have an old LG DVD Burner. Installed it myself roughly 3 years ago. Its an old 4x burner. Been working with no issues until recently. As always I used DVD Shrink to create an ISO image of a DVD. When trying to burn this DVD, my burner freezes at 2%, and an error occurs while recording. I’ve uninstalled and reinstalled drivers, and tried updating it. Any suggestions?