CDex won't run in WinXP user account

Can anyone offer advice on a CDex problem?

My computer OS is WinXP Pro. I installed CDex - like any new program - when logged on as Administrator. When I logged on to my User account (which for security reasons I prefer for normal daily use), CDEx couldn’t even “see” my CD drive. After some dialogue and advice from Cressida in this thread
http://club.cdfreaks.com/showthread.php?t=206226&highlight=br1anstorm

I downloaded and installed Nero BurnRights. After this, CDex could see my CD drive, and could access CDDB for album info.

BUT… when I tried to rip CD tracks to mp3, the program simply froze. My TaskManager showed that the CPU was running at 100% and CDex was ‘not responding’.

When I logged on as Administrator, I was able to use CDex perfectly well: it successfully ripped tracks to mp3 and did playlistings etc.

So does anyone have any idea why CDex won’t work in a User account - and what I might do (provided it’s not too technically complicated) to solve the problem?

br1anstorm

Hi,

normally, installing and configuring (!) Nero Burn Rights should work.
You might try this: Uninstall CDex and remove all remainders from the harddisc and registry. Reinstall CDex then (I am still using version 1.51). Also, adjust CDex to use “NT native SCSI library” (somewhere in the options/preferences)

If that still does not work, then get Nero’s Aspi drivers from www.nero.com and put the file into the CDex program directory.
Additionally, make sure Adaptec Aspi is not installed.

[I]EDIT: I just saw, that these hints were already given by Cressida :)[/I]

Michael

Thanks, mciahel… as you’ve noticed, I went through exactly these steps at Cressida’s suggestion when I first installed CDex.

I tried with the ‘NT native SCSI library setting’ first, and when that didn’t work, I checked that I didn’t have the Adaptec aspi, downloaded Nero’s aspi drivers and BurnRights. That’s why I’m puzzled that CDex freezes when I try to rip when I’m logged on as User… Is there simply a setting in CDex, or some configuring of Nero BurnRights, that I need to adjust, I wonder?

br1anstorm

Hi,

did you configure Nero Burn Rights to “allow all users”?
You might also try the older CDex 1.5.1

My computer is running W2k, and I always use a restricted user account. I don’t have any problems with CDex (of course, there is no Adaptec Aspi installed)

Another idea: check all the settings of CDex that refer to directories. The paths should point to somewhere, you have write access to. If I remember correctly, there were some settings, that pointed to the CDex program folder.
In doubt, you could grant “write” and “modify” access for your user account to the CDex directory. On XP Home you need to boot in Safe Mode to do that, on W2k and XP Pro, these options are directly available. Of course you’ll have to be logged on with administrative rights to change the permissions.

Michael

Michael

Thanks - I think we may be closer to a solution. First off, the CDex version I have is 1.51. And I have configured Nero Burn Rights to allow all users (you have to set up a “Nero user group” and list all the accounts which you want to include).

But I think your idea about directory settings may be the answer. Which leads to a slightly dumb question: should the directory settings be different for CDex in each user account? I set up CDex initially in my Administrator account - so the directory entries (which I suspect originally appeared as the defaults, as I don’t think I actually entered them) point to folders on the C drive which belong to my Administrator account. I’ve just checked the configuration settings for CDex in my user account. They still show the paths to those same folders on the C drive which belong to me as Administrator. So would I be right to think that I have to change these to the pathnames/settings which point to the equivalent folders in my User account? Just thought I’d ask before changing them all!

br1anstorm

I wonder if the question in my previous post was so dumb that everyone thought it didn’t deserve an answer…

I know that one approach is to ‘suck it and see’: to try changing the directory settings and see what happens. But I hesitate, because at present I can rip and save tracks quite happily when logged on as Administrator (ie I have half a loaf, which is better than none at all!). If I log on as User, and change the CDex directory settings to point to folders in my User account, I’m concerned that I might end up not even being able to run CDex as Administrator.

I guess what I’m asking is, can Cdex be set up so as to have the configuration tailored differently for each account on the system? Or if I change settings when logged on as User, will this affect the settings I made when logged on as Administrator?

edit: I notice on re-reading earlier posts that you have to have Admin rights to change the settings. So my question may be redundant, because this implies that I have to log on as Administrator in order to reconfigure CDex to point to folders which I can access as User. If so, then I think I have answered my own (dumb) question!

br1anstorm

Hi [B]br1anstorm[/B]!

It’s really as simple as you think, CDex can’t write to the Admin documents folder when you’re logged in with a limited user account. You can do two things, either

  • right-click your CDex shortcut and “Run as” Admin, or
  • set CDex folder paths to the User documents folder as suggested

You may also want to give your user account “write” rights for the CDex program folder, in order to remember program settings and display confirmation of ripped tracks.

As mentioned elsewhere, CDex goes back a long way and as such predates multiuser XP environments. You’ll have to take this into account and make the necessary adjustments yourself (or find another ripper that works from your limited account as is).

Thanks Cressida - once again you have come to the rescue and explained things. I confess I wasn’t aware of the right-click and “Run As…” option before (I’d simply never heard of it!). But I think I’ll change the folder settings anyway. It makes more sense to keep my ripped tracks in my User folders, as I log in as User most of the time.

You suggest I also give my User account “write” rights for the CDex program folder. At the risk of pushing my luck with another question, how exactly do I do this? I have listed my User account as part of the “Nero Group” for BurnRights. Do I need to tweak any other settings, and if so what and where?

Thanks for being so helpful to a relative newbie!

br1anstorm

You’re welcome. I have used a limited user account in Windows myself, so I know a little bit about it (I mostly use Linux now, which does this by default by the way).

You may find that not only CDex but other (older) programs as well don’t store your settings and preferences with a limited account. Giving the account user additional rights to write to or modify the program folder will often solve this. What you can do to achieve this is add a “Security tab” to “Folder Properties” with SCESP4I.EXE (wherein you can add your user account to gain access to the folder in question). See here for example for more details. I’ve used this with both XP Home and Pro without problems.


Thanks Cressida, that’s very clear, and helpful. I’ve now sorted things out…

Many thanks again (what would I have done without you!)

br1anstorm