CD Speed jitter test problem

vbimport

#1

I have a big problem measuring jitter with my LiteOn 165H6. Naturally I’m using CDspeed 4.7.0.0.

After the drive spin-up there is a delay before the Disc Quality scan starts. This delay seems to increase with each scan. The delay can get to be twenty minutes or more. The only way I can get back to a reasonable delay is by re-booting.

If I disable jitter on the advanced menu, the problem goes away. Of course the jitter test goes away too. :slight_smile:

During the delay, something is keeping the CPU busy. Task Manager reports about 40% utilization. Strangely enough, Task Manager shows no processes using the CPU, not even CDspeed. System Idle Process is using 98% of the CPU but the CPU is around 40% busy. I’ve never seen this before.

CDspeed just sits there like a bump on a log, but eventually it will start the scan.

Here’s a picture of the wierd Task Manager display. The processes are sorted by CPU usage. And a picture of CDspeed doing it’s imitation of a bump on a log.


#2

I forgot to mention one thing. This delay happens regardless of the scan speed. If the speed is other than 4x then it won’t show jitter, but the delay still happens. The only way to eliminate the delay is to disable jitter on the Advanced menu.


#3

Have you tested a previous version of cd-dvd speed? In this way you can exclude a problem specific of version 4.7.0.0


#4

Only this version will show the jitter on my Liteon. The jitter scan is the problem. Older versions of CDspeed would show jitter on Benqs, but only this version has added the Advanced menu which will allow jitter testing on Liteons.

Good try though :smiley:


#5

I have the same problem as you with my liteon LH18A1P, Steve b.

I don’t know why it goes all spastic like this. Sometimes jitter works straight away, other times it takes a little while and my CPU is slowed down while it’s trying to start jitter testing.


#6

It’s good to know it’s not just me. I don’t recall seeing this when I first started jitter testing.

I’m wondering if it’s a Windows update or maybe my bloated McAfee anti-virus stuff.

But my delays aren’t small. Five or ten minutes or more.


#7

I don’t know if it’s related, but the DVDscan program is now giving me problems.


#8

I just installedFrog Aspi version of wnaspi32.dll in place of the Nero wnaspi32.dll in the CD-DVD Speed program folder, and the jitter scan seems to be working with the SH-16A7S. Note that this is the only ASPI .dll on my system (Nero is not installed, and I killed the adaptec ASPI that seems to automatically install with Kprobe).

FrogASPI can be obtained at http://www.frogaspi.org/download.htm - and I used the one “already renamed as wnaspi32.dll”


#9

Most interesting. :slight_smile: - thanks for the link.


#10

I may try the Frog next.

I have 5 XP installations here and none of them will start the jitter scan reliably.

I have 1 Win2k installation and this one does the jitter scan okay.

The Win2k is a “barebones” system with only Nero installed. InfoTool shows no “System” aspi installed but it does have the “Nero” aspi installed. After much testing with XP, I’m not sure this is relevant.

I also have a “barebones” XP installation and no matter what I try, it doesn’t start the jitter scan. I tried putting the Nero aspi in various folders, but it had no effect on CDspeed. InfoTool showed no aspi installed. I then installed Nero and now InfoTool shows “Nero” aspi installed. But jitter test still doesn’t work.

In the end, only Win2k works. None of the XPs will run the jitter.

By the way, I found a surefire way to get the jitter test to start. Just run InfoTool. As soon as InfoTool scans for drives, the jitter test will run. Unfortunately this puts a spike in the scan, so it’s not a good solution.


#11

My Dell 9200 system is running XP (Home Edition), but I did not test anything rigorously. Just deleted the Nero wnaspi32.dll from the CD-DVD folder, replaced it with Frog wnaspi32.dll, and ran the Quality Scan test with jitter checked in advanced options. Rebooted and ran a Quality Scan again. Both times, the Quality Scan started immediately after drive spinup, and showed jitter. But that is the extent of my “study.”

p.s. Before any of this, I had run killaspi, and based on http://www.tricerasoft.com/aspi.html I checked to make sure no other files were lurking (seems to me I removed one from the system32 folder).


#12

Got home tonight (computer had been left on) and the Quality Scan wouldn’t work. Rebooted, didn’t work. Changed Frog wnaspi32.dll back to Nero wnaspi32.dll, still wouldn’t work. Watched part of a DVD in Sonic Cineplayer. Tried Quality Scan again and it worked. Rebooted, this time never firing up Sonic Cineplayer, tried Quality Scan and it worked. Changed DVD, tried Quality Scan, and it wouldn’t work. Rebooted, loaded DVD, fired up Sonic Cineplayer, then tried Quality Scan, and it worked. Rebooted, didn’t fire up Sonic Cineplayer, and it still worked. Changed DVD, and it worked yet again.

Can’t figure it out. Will leave the computer on and see if it works tomorrow.


#13

Well the Win2k system that ran the jitter test without fail a couple of days ago now won’t run the jitter test.

A very strange problem.


#14

Unfortunately this is a common problem with the jitter test.
But in the next version jitter will be measured seperately (after the PI/PIF test) which is more reliable, more accurate and a bit faster.
In the new version jitter can also be measured with all speed settings.


#15

Erik, you da man! Now I won’t have to wait for a full moon to get the jitter test going. :clap:


#16

I’ve been having this same issue on my DFI ICFX3200 and was beginning to wonder whether there was an issue with the SB600 south bridge.

Any time estimate on the new version, or even a beta version?


#17

In the new version jitter can also be measured with all speed settings.

The first thing I did with the new version was to try a jitter scan at 8x and got nothing ?


#18

I don’t think that the version Erik mentioned is available yet. Look at the scan he posted and you’ll see version 4.7.[B]4.9[/B]. The latest generally available version is 4.7.0.2.

G


#19

Look at the scan he posted and you’ll see version 4.7.4.9

OK, thanks :o I did not look that hard at the scans, I just read the test as I was posting from a very slow link at the time (15 KB/sec, how I ever managed with 56k let alone all the slower stuff I had before that, I dont even dare to think what my 300 & 1200/75 baud modems would be like now and I only have a 3.5 meg connection at home.

But I do sometimes get the jitter test being very slow to start, but not like the speeds I see others have (I only run Win 2000 and 64 bit 2003 and have always used Force ASPI v1.7) had. All less that a minute, but something I did find was that I have a few links to older versions of CD Speed. I only have one version in the Nero toolkit folder, and the others are in my software archives and used to use the ‘start in’ bit in the properties box to fool it into not needing the ASPI and GDIplus libs. But since moving them to the folders they run in there have been no start up problems that I have seen.

Thanks go to ErikDeppe for this program, IMHO it has improved my DVD burning experience greatly.

I just have one very small niggle… the save data explorer window its not re-sizeable any more and I find this a bit of a pain as the file names I work with are always quite long and its nice to be able to have a big window to do this with… I hope this would just be a compile time switch for you to change, if it is a big deal in the code I will put up with it.