CD-RW Drives

vbimport

#1

Hello all am new here to the forums and are in need of help I just formated my hardrive its gateway really old comp has an athlon 1.2ghz, anyhow this comp had win me on it I formated and installed an oem version of win xp. Now I am having problems with the cd rom drives that are installed in the computer, I have searched (googled) the net for the drives and on both manufactures website I find no drivers also I searched gateways website but they have nothing as well this computer is about 4 years old. I’ve also tried driverguide.com and found no drivers for either drive I dont know why I cant see the drives in MY COMPUTER. Can sombody help plzzzzzz I cant do much with comp without drives :confused:

Drives are: LG CD-ROM CRD-2483B and SONY CD-RW CRX1611

here is a screenie for u guys to see n help me out a bit better

Also as u guys can see from screenie I have other devices with exclamation points right now drives are what are more oimportant to me, Thanks in advanced for your help :bow:


#2

You will need to get drivers from Gateway for the other devices, if they have them for XP. Win2000 drivers might work in some cases.

The optical drives do not require a driver. The standard trouble-shooting steps apply here. 1st, turn off the native XP burning service. 2nd, make sure that you are running the Windows MS IDE controller drivers and nothing else.

Are the drives identified correctly in BIOS and set to Auto detect?
Suggest you try uninstalling the IDE controller in device manager and rebooting to force a re-install of the IDE driver.


#3

yeah the drives are recognized in bios and are set to auto , i tried uninstalling ide adaptor but still no luck is there some were ese i can get drivers ?

also I did try every driver from that was available from gateway to no available solution. :eek:


#4

Expand the IDE controller in device manager and report back. You should see the primary and secondary channels, and something like “standard dual channel PCI IDE controller” This is the actual controller driver should show with the MS driver.

You have a VIA chipset and you may have installed the wrong IDE controller driver for Win XP. So if the controller shows up as a VIA IDE controller instead of the above, you have 2 choices. Either revert to the default MS driver or go find the updated VIA drivers. It used to be called “VIA 4in1”, and that’s what came on the Gateway systems. Some of those boards work better with the VIA IDE driver, some work better with the MS driver.

If you need help switching to the MS driver, just ask. But it’s in the list in the wizard for updating the drivers.


#5

ok yea it says via ide controller I did install the 4in1 driver from via… now how do i get the windows ide driver so i can try those?


#6

I also wondered if you tried installing any of the old burning software that came with the system? Please say you didn’t. :wink: There’s a few known issues with the old burning programs that cause this and it requires a registry cleaning to fix.

To switch drivers, open the IDE controller driver as above…go to properties - driver and select “update”. That opens the driver update wizard. Select the option to display a list of known drivers. It should show you a list with the VIA and the “standard dual channel” driver, and that’s what you want.

Reboot and see if it blows up. :bigsmile:


#7

lmao its not gona blow up :Z will try that thx for info… as far as isntalling anything i havent i just installed winxp fresh dont have recovery cds they broke :frowning:


#8

Then XP must have installed the VIA driver? :confused: I didn’t know it would do that. I wonder if Gateway doesn’t have an XP-compliant VIA driver for that chipset, but surely VIA does.

The similar system I had worked fine with Win2000 and the MS driver. But it also worked fine with the 4in1 driver from VIA. Win2000 does not install a VIA driver though, so I’m guessing thet XP installed an old one. You can try updating XP to SP2 with all the updates and see if that helps, it might.


#9

it does have xp sp2 :frowning: dont knwo wtf but I will keep you posted I still have not tried changingide drivers yet am not I home were pc is atm will go ithere in 15 min


#10

OK guys am back still no clue Ive tried everything u guys mentioned and still dont know wats going on Also As u noticed from the screenie I have and exclamation point on one of the audio controllers yet I uninstalled those drivers and disabled onboard audio and then I installed a Santa cruz soundcard and still have problems there still and exclamation point I have a feeling that If I remove those other two cd rom drives and put new ones in I would get same thing here is screenie.

Also in bios I can see the drivers they are set as .
secondary ide master[ATAPICDROM]
secondary ide slave[ATAPICDROM]

I dont know if that helps much :confused:


#11

It wouldn’t hurt to replace the IDE cable.
What exactly does Windows have to say about the drives in device manager?


#12

ok sorry for not posting back but I just got the power back on there was an outage in my area and couldnt post…will try replacing ide cables and post back tomorow Thx for helping out.


#13

Ok guys I removed one cd drive and left the sony cd-rw drive in and I am still gettting those expclamation points at this point am still lost as to what it could be right now I have 3 exclamation points as u can see from the screenie(ignore lg driver this is no longer there) I have an exclamation point on plug and play software device enumurator could this be the guilty prick ? :confused: on a side I also use a new ide cable to rule that out and removed the lg drive from system I dont know what else to do :Z


#14

Well, you can uninstall the “device enumerator” and see what happens.

The sound card will need a XP driver from the card maker or from gateway.

Assuming you didn’t install anything that messed up XP’s use of the drives, maybe the issue is lurking in BIOS somewhere. One quick way to test a drive is to boot to the Windows CD. If it boot’s, then the drive is reading OK in DOS.

Edit: You didn’t say what XP is actually saying about the drives in Device MAnager. It should show the driver details as “cdrom.sys” located in the system32/drivers folder.


#15

yeah the drive boots the cd ok thats no problem I did try and update the bios and it wouldnt update I dl the bios from gateway too


#16

You didn’t say what XP is actually saying about the drives in Device MAnager. It should show the driver details as “cdrom.sys” located in the system32/drivers folder.


#17

Ok here ya go screenie :bow:


#18

OK, driver is fine, but what does XP say about what’s wrong with the drive?


#19

it says…
"windows cannot load the device driver for this hardware. The driver maybe corrupted or missing (code 39)


#20

And you swear to God that you haven’t installed any software on this system? No removable drives, card readers, virtual drives, burning software or anything.

Since it’s some sort of OEM version of XP, is it on a regular Microsoft CD?