Cd rw drive disappered

Hi everyone!!!

quite recently my cd drive has compleatly disappered. i have tryed to find it in device manger but no luck. i have no secondary IDE channel if that is significunt. when i put a cd into the drive the green light flashes and the cd spins but apart from that nothing eles happens. you help would be greatly appreciated

Hi there, and welcome aboard!

Well as you don’t have a secundary IDE channel, I think the problem lies there, as a drive cannot be accessed without a working IDE channel, right?

How this IDE channel dissapeared? Did you perhaps (accidentaly) disable it in your systems bios? If not, try (re)installing your chipset drivers and see what happens.

how might i do this [sorry iam a noob]

Originally posted by bobmonkey
how might i do this [sorry iam a noob]

I think you just answered my question… if you don’t know what the BIOS is, you probably don’t know how to enter it and disable an IDE channel… :wink:

Can you perhaps post some more system specs (mainboard, other IDE devices, IDE setup, OS, drivers etc?).

here is a pic of what i see when i acess device manger i hope this will help


You need to install drivers for USB.

Try uninstalling Primary IDE Channel.

Originally posted by BoSkin
[B]
You need to install drivers for USB.

Try uninstalling Primary IDE Channel. [/B]

I know my question is bit deviating from the thread point . but i need to know if connecting drives in 40pin 80 conduction does helps in improving interface transfer rates?

Hey Bob
Welcome to the forum, did you happen to take the computer case and unplug a cable by chance??

i have not removed any wires iam sure of that i have tryed deleated the primary channel and it re-installs inself but nothing more happens. I will now check how to get to cd drive to see if any wires have been dislodged. Any help would be great.