CD-RW disc is no longer recognized

vbimport

#1

Ok, I think one of my CD-RW discs is dead or dying. It is no longer recognized in Windows or by any programs and it sometimes freezes the computer. Other discs, commercial CDs, CD-Rs and CD-RWs seem fine but not this one. It’s an old Memorex 4x rewritable (made by Infodisc, which is crap, I know). It’s not too big of a deal because other brands work fine but I’m curious if this disc is beyond all hope. Is there anything I can do? What causes this? It wasn’t used all that much, bought a while ago but was sealed in plastic wrap etc. Didn’t erase it all that much either. On the other hand, maybe I shouldn’t be surprised as I found many posts saying that Memorex 4x rewritable that are made by Infodisc are utter crap (luckily, I only bought a couple of these when I did). I found some old post with a similar problem and someone suggested putting the disc for 20-30 minutes in the sun… Was that a joke? How would it help? I guess it would do something to a disc’s dye. :slight_smile:

PS The burner is LTR-48246S.

PPS Hmm, this may be better at media forum, so feel free to move it.


#2

@ Elrik
Yup this probably belongs in the ‘media’ forum but…Try a full erase(full format) then try to write to it. You may have to do a full erase each time, that is the best way to get good results from any RW media. It may be also just old and unwriteable too.


#3

Try several cycles of quick erase than full erase. Try erasing with several different programs, like CDSpeed and others.
Uninstall any packet writing programs like InCD or DirectCD. And never buy Memorex CDRW media again. :iagree:


#4

Thanks, guys but none of the programs I tried to erase with so far (Nero and Alcohol 120%) even saw the disc at all. For example, in Nero, it’ll simply pop up a box saying “Please insert a CD-RW disc” and no matter how many times I “insert” it, it just won’t see it. Just not long ago I was erasing it fine but not anymore. It’s like it decided to stop being a CD-RW disc. If I try to access it from Windows Explorer, it simply freezes most of the things on the computer, can’t even close Windows Explorer, and the drive tray will no longer open. I have to reboot to even be able to get the disc out of the drive after it. I tried this disc in another computer and it freezes it too. Doesn’t happen with other CDs. Yes, this Memorex is awful. While there don’t seem to be any scratches or strange artifacts on the dye itself, it’s just a poor poor media. And nope, never bought any Memorex CD-RWs aside from these two. I have been using Memorex CD-Rs though and Verbatim CD-RWs and they always worked fine but they’re not Infodisc. :smiley: