Cd-Rom Problem

When I put a cd in my cd-rw or cd-rom the label comes up as the drive icon. Now when I eject its supposed to dissapear. On my machine it will only dissapear if you restart the machine and any cd you put in always has the same label???

Any Ideas

:bow:

Try hitting F-5 or View | Refresh to refresh the screen.

I’ve tried that.

no matter what I do it won’t refresh to the correct cd label.

:eek:

Have you tried removing the CD, closing the tray, and exiting Explorer?

When your reopen Explorer is the previous label still shown for the empty drive? If not and the drive properly shows no label, then inserting the new CD should bring up the correct label.

UT2K3 and The Sims do this me. Dunno how to fix it yet…

jonnypho
Windows has a known flaw that involves the caching of the CD. If you insert 2 consecutive CD’s that have the same name or even just similar contents, Windows may assume it is the same disc in the drive. Windows holds that CD, ( or TOC), in cache untill a different one is inserted. I ran into this issue with CDR’s burned in Nero, because they all have the label “new”, unless you type in a different one.