CD-Rom powers on but not reading, might be bc of ultraspeed CD-RW incompatibility

vbimport

#1

My burner is a TDK32x10x40. I bought some Memorex cd-rw’s, but I failed to notice that they were only compatible with ultra-speed 16x-24x cd-rw discs. I tried to format a DirectCD disc and then I got the message “medium not ready.” Ever since then I haven’t been able to read cds. My cd burner won’t read any cds. When I pop in a cd the light blinks so I know it powers on, but I don’t hear it spinning up. I tried swapping out the burner to a cd-rom and the problem was still there. Ever since then I haven’t been able to read cds. Can someone please help me?


#2

Is everything connected correctly? like IDE cables and such.
Do you see the drive in My computer?
Do you see it in BIOS setup?


#3

Everything is connected properly. When I installed this drive, I swapped out my old cd-rom and connected the same cables. I’ve had the drive for several months already and never had any problems with it. I see the drive in My Computer and the BIOS setup.