CD ripping = broken :O

Ripping from an Audio CD no longer works on my comp. Used to do it all the time with Musicmatch. (tried other progs, but still doesn’t work)

Messed around with ASPI drivers, to no avail.
Cleaned out all ASPI entries in the registry – did nothing.
Tried Audiocrusher (supposedly doesnt use ASPI) - error: “SCSI passthrough error”.

Uninstalled DVD and CD-RW drives through device manager, they reinstalled upon bootup. Now displayed as SCSI drives… :S (not sure that this is new, but seems odd either way), didnt change anything.

Removed ISObuster, Daemon tools, Nero, Blindwrite (all which create virtual CD drives) (thought this might clear things up).

Still doens’t work.


Any suggestions??? I’m stumped.


P.S.:
System specs:

AMD AXP 1900+
Soyo K7V Dragon+ (KT266a)
using onboard Cmedia sound
Pioneer 16x DVD on IDE1
Sony 24x10x40 CD-RW on IDE2
Maxtor 20GB on IDE3
WD1000JB on IDE4
(promise raid controller, setup for use as extra IDEs)
Windows XP Home

It appears that as both of your optical disc drives are being detected as SCSI drives, this may be enough to confuse CD ripping software. I’m not even sure if you can burn with your CD-RW drive if Nero sees it as a SCSI drive instead of an IDE drive. :confused:

Another thing you can try is uninstalling the IDE controllers them selves. Open the section ‘IDE ATA/ATAPI controllers’ in your device manager and uninstall the secondary IDE channel or the channel where your optical drives are on. Reboot the system and after it re-detects your IDE channel and drives, go into the properties of the IDE channel you previously removed, click on the ‘Advanced Settings’ tab and make sure (or set) the Transfer Mode for both Device 0 & 1 to ‘DMA if available’.

Another piece of software you can give a try is Exact Audio Copy (freeware). This software goes through a lot of different ways in trying to rip audio from an Audio-CD. The software also supports FreeDB, CD-Text, burning and secure audio ripping where it checks everything block twice as it reads.

http://www.exactaudiocopy.de/ :cool: