CD Reading Problem causing me insanity

vbimport

#1

PLEASE HELP, this problem is eating at my sanity.

I have a problem reading CD’s. The problem persists with multiple drives and multiple OS’s (same PC). I have a Lite-On 411-S DVD-R/CD-R combo drive. At first, it worked fine with CD’s and DVD’s. Then it would simply not recognize CD’s. It would spin the CD for a while, and then act as if there was no disc in the drive. My system dual-boots WinXP and Linux. The same problem exists in both OS’s. The drive continued to read/write DVDs correctly. I updated firmware to newest available, but the problem persisted. I figured the drive was toast, so I RMA’d it, buf after installing the refurb, the problem persisted still. So, I BOUGHT A BRAND NEW KHYPERMEDIA DVD/CD combo drive, and LOW AND BEHOLD, I STILL CAN’T READ CD’s, even after applying newest firmware!!! Both drives can read/write DVD’s fine, but simply do not see CDs.

Interestingly, if a CD is left in the drive during reboot, the PC does ask me if I’d like to boot from the CD, but I have no bootable CD’s (nor any way to make one…), so I have no idea if it would actually boot the CD or not.

Seeing as how I am not a complete moron, I have already replaced the 80-conductor IDE cable to no avail. I have tried the drives on the primary and secondary IDE chains, and have tinkered with all the logical jumper settings. I have also checked all the related settings in my BIOS (newest avail BIOS). It should be noted that both OS’s are able to correctly use the drives in UDMA Mode-2.

I have also tried using the newest windoze IDE drivers from SiS, and from GigaByte (my mobo manuacturer).

I am at a complete loss. Could this just be case of bad luck, and all 3 drives have a laser-allignment issue? If so, that would be one HE11 of a coincidence!

I have a GigaByte mainboard, GA-8SG667 (SiS 648 chipset). Any advice would be much appreciated. Thanks.


#2

@ large satchell
welcome:). Could be a weak or failing PSU.

please do not cross- or double-post.


#3

Insanity is not a bad thing. You don’t have to be insane to be a Freak, but it sure helps.

Sounds like a software conflict to me. More than 1 program trying to do something with the CD when you put it into your drive. First remove any and all packet writing aps that you have, check to see if you have how many programs that are trying to do something (read) a CD when it is put into the drive.


#4

Try a DOS bootable floppy with the DOS IDE drivers from
your IDE device ie SiS 648 … if it boots to DOS and you can
see and copy a CD … then Most likely Not a hardware problem …

My new xmas Khypermedia 52-24 CW099D would make
windoze hang on bootup until i checked it was OK with
a DOS floppy and then when replaced SIIG IDE PCI board
win drivers with older version … it booted fine to win.

It was still erratic with SIIG drivers so i dug up old
1998 Intel piixide driver for TX430 momboard and hooked
CD to momboard IDE … Nirvana … CD-Speed reports 18MBs
burst transfer rate … (after finding out new 80 wire cables
Only have 39 holes in connector and will Not fit in old 40 pin
slots) :rod