CD/DVD Optiarc 7560 Stopped Working on my HP

Hi, I dont know exactly when it happen’d, I believe it was right after I did a bunch of new updates to Vista but my DVD RW
(optiarc dvd rw Ad-7560A ATA Device) - stopped being able to read either dvds or cds.

It shows up under system manager as the optiarc and i have tried uninstalling and reinstalling the drivers, even deleted the drive, shutdown, and reinstalled driver but nothing works.

My computer is not that old. It is an HP Pavilion dv9819wm Entertainment Notebook.

I have tried locating correct firmware (i think!) and updating to no avail, does anyone know how i can fix?!?

quick search found this: Link
Looks like someone may have done the same as you.

Yes. I tried that one and updated firmware to DX14.

I also tried going to the regedit trick and deleting upper & lower filters.
http://support.microsoft.com/?scid=kb%3Ben-us%3B314060&x=12&y=13#nextsteps

Problem is when I get there I dont see upper/lower filters listed.
All I see at the address is (5) folders in left pane marked:
0000
0001
0002
0003
Properties

under folder 0000 in right pane it says:
Default
DriverDate
DriverDateData
DriverDesc
DriverVersion
InfPath
InfSection
MatchingDeviceID
ProviderName

under folder 0001 - 0003 in right pane it says: same as above

under folder marked properties, i click it but a windows box pops up and says “Error opening Key” at top of pop up box and then in body:
“Properties cannot be opened. An error is preventing this key from being opened. Details: Access is denied.”

No “upper” or “lower” key tag in right pane anywhere under that address listed in the microsoft help link.

I am using Vista and am in admin mode so dont understand!

Computer Specs:
Vista - Home Premium
Service Pack 1
AMD Turion 64 X2 Mobile Technology TL-62 2.10 GHZ
32 bit operating system

So I am still at a loss!?!