CD/DVD drives won't read, Two seperate drives

vbimport

#1

I’ve been having trouble with both my USB DVD drive and my IDE CD-rw drive.

Both drives won’t read cds. SOMETIMES (very rarely, once so far in the past two weeks) they will read the cd. I’ve tried many different cds, none work. The disc in light will blink when I insert the cd for several seconds like it’s reading it, but then explorer will show no cds in the drive, says please insert cd, etc. I’ve tried updating the firmware for my IDE cd-rw, I’ve tried updating to XP SP3, deleting the drivers and restarting.

I haven’t removed any software at all (I’ve seen the fix for like Easy CD creator, but I don’t have that, only ahead Nero, which hasn’t been edited) This problem really came out of no where. I use Power ISO and Magic ISO from time to time, and that’s the only thing I can think of that may be causing problems. I’ve tried enabling a virtual drive and using my regular cd drives, no difference. I haven’t uninstalled either program, but I have used them recently.

If there’s been a thread on this I apologize, I’ve tried to search for this on google as well as this forum, and my problem seems fairly unique since it’s got nothing to do with Easy CD creator or a hardware problem (Obviously, it’s software since both drives won’t work.)

Also, During my computers bootup process, it displays the drives correctly (Philips CDRW 2412a and HP dvd740.) In device manager, both drives show up correctly and show as working properly under CD/DVD devices or whatever.
However, There’s an unknown USB controller with that yellow question mark under a different category (No driver installed for it.) My only two USB devices are my mouse and my DVD drive. I’ve tried removing them both, and it still remains. I’m pretty sure this is something that has come up recently. I can’t be sure, but I don’t recall seeing it much longer ago.