Cd drive... reading discs, not burning

vbimport

#1

Hello there,
I’ve searched every site for help, but all recommendations haven’t helped. My Asus Cd drive will read dvds and CDs but won’t burn either of them. When I put a blank disk in it says “windows can’t read the disc in drive E:. Make sure that the disc uses a format that windows recognizes.” I’ve tried a few different discs, all of which have burned before. I’ve tried running Fix it to no avail. I tampered with regedit and tried finding the HIkeys and lokeys as some sites have recommended and found neither. I’ve also uninstalled/disabled/ updated drivers and firmware and still nothing. I even bought an external drive because I needed to get files to disc asap, but I’m having the same issue. What else might I be missing?


#2

Hiya :slight_smile:

Which version of Windows are you using? And are you using any separate burning software?


#3

I’m using windows 7. Thanks!


#4

To do a little troubleshooting, download ImgBurn & try to burn a disc using that. (Note: when installing ImgBurn, make sure you select “Custom Setup” to deselect any value-add software, and/or temporarily disconnect the computer from the Internet so the installer doesn’t even offer anything extra. ImgBurn itself is safe, but the value-add software that might be offered is completely unnecessary and sort of annoying to remove.)

Hopefully you’ll be able to succeed at burning a disc this way, and if ImgBurn detects anything blatantly wrong, it tends to tell you in its log.


#5

Thanks Albert! That program works, now why won’t any other app work?


#6

This may not be the problem but should be set this way anyway.
Right click on the drive & select properties.
Then the Recording tab.
Set your drive as the default burning drive.



#7

unfortunately it isn’t showing the record tab! It does show a sharing tab but I’m not able to adjust anything in there.


#8

Do you have any other recording software installed? Do you know how long it’s been since the built-in Windows burning tool worked?


#9

Try this:Step 1
a. Click Start, and then click Run.
In the Open box, type regedit, and then click OK.
Click to open the following folder:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CD Burning\Drives
To edit the drive type so that Windows recognizes the drive as recordable, follow these steps:
In the navigation pane of the Registry Editor window, click the Volume{GUID} folder under Drives, where GUID is a 32-character identifier.
Step 2
Note If your computer has more than one CD drive, an additional Volume{GUID} folder is listed for each drive.
In the right side of the Registry Editor window, double-click Drive Type.
In the Value data box, type 1 if the drive is a CD-R drive or 2 if it is a CD-RW drive.
Click OK, and thenTo see whether Windows recognizes the drive as a recordable device now, follow these steps:
Click Start, and then click My Computer.
Under Devices with Removable Storage, right-click the CD-R drive or CD-RW drive, and then click Properties.
If the Recording tab is displayed, Windows recognizes the drive as a recordable device.
Click Cancel. close Registry Editor.


#10

Thanks Cholla, I tried that as well. I don’t understand why it would do the same thing with an external cd drive as well that I just purchased?


#11

Have you tried running :
sfc /scannow from a command window?

That is supposed to restore system files .

Going with what Albert posted " other recording software" that is currently installed or even the same that has been uninstalled.
A bad uninstall can cause problems like this . Or a software that is installed currently can too.

Before you try uninstalling all your “recording” software & reinstalling any that you’ve uninstalled then uninstalling it again.

This will sometimes fix this problem.
Install Virtual CloneDrive from slysoft.
http://www.slysoft.com/en/download.html

If that doesn’t help you can just uninstall it if you don’t want it .