CD drive not reading CD's

vbimport

#1

Hi Ihope someone can help with this problem.I have a combo dvd\cd drive and it now wont read cd’s.I can read and play dvd’s and burn cd’s but when i insert a cd Iget “drive not formatted error”.If I go through the sequence of "do you want to format this drive"etc I get "this drive cannot be formatted"error.I am running win me.Any help is greatly appreciated :confused:I have re installed original cd drive and get the same result.


#2

can’t say for certain that this will fix it, but many of these drive cannot read data on CD issues are caused by a non-existant or corrupt aspi layer. download and install it from http://asia.cnet.com/downloads/pc/swinfo/0,39000587,39059205s,00.htm


#3

Ghosters thanks for your reply.Tried what you suggested no good result.I have tried just about everything to try and fix this problem-short of reinstalling everything which I dont want to do as it is a business computer.The cd’s are identified in Nero tools but will not play.thanks from a fellow Aussie


#4

have you installed any new software before it stopped reading cd’s?


#5

ZigZag Man
I have had this problem for a while so am unsure about the sequence of events .I havent loaded any thing major on to the pc recently as it is a business machine that I try and keep ‘clean’.It has to be a software problem somewhere but where?I have tried disabling the drive in control panel and reinstalling-no effect


#6

Have you tried re-seating the ide cable, thay are known to vibrate loose sometimes.


#7

ok here is a good way to see if its your drive or software/firmware is if you have any bootable cd’s (ie your windows installation cd) put it in at bootup and see if windows trys to boot from it, if it qwont boot from the cd and goes into windows then you need to return your drive or buy a new one. if it does then your drive is ok, and all i can think of is to reinstall windows witch only takes about 1 hour, or try getting new drivers from your drivers website, you didnt say the make or model of your drive if so i mite be able to find the drivers or firmware for you. hope this helps, ben, or email/msn me for assistance :slight_smile:


#8

This normally occurs when you access a new disk that is not pre-formatted or is a format that Microsoft Windows cannot recognize ie using Apple Mac format in a PC. Of course it doesnt exlude a hardware failure.

You do have a PC right? What kind of disks are you trying to read? Does it do that on all media that you try to read?


#9

Thanks for replies .I havn’t given enough information
Problem:when I try to run a cd in my Liteon dvd\cd drive(it uses generic MS driver no driver on liteon website) I get "disk not formatted "."do you want to format this disk"if click on yes then “this drive cannot be formatted”.I can burn cd’s and run dvd’s.Nero toolkit will recognise the cd and report on data
System:dell p3 600mhz
OS: Win Me
Things tried:reinstalled original CDrom drive -same result as above.Removed all Nero and Ahead programs using Ahead clean.same result.removed dvd software no difference.removed adeptec drivers(why is there a scsci driver for an ide device?).This is driving me crazy any help is most welcome. :bigsmile:


#10

did you try wot i said in the email:)?