CD drive door locks up until reboot

vbimport

#1

I have had a problem with my CD drive locking up and not responding at times. I tried a firmware update with my old drive and it seemed to help some. It was still doing it so I recently bought a new LiteOn CD drive. The firmware is up to date. This drive is better but still has the problem. The old drive would lock up after playing a music CD. This new one locked up while installing Empire at War.

Any help?


#2

power problem perhaps?


#3

I do not think it is a power problem as it always works fine with a Restart. It seems like a software problem or perhaps the way the jumpers are set. I have the Master/Slave set to cable select.


#4

can you still access the drive when it’s stuck?


#5

I was unsure so I tried a music CD and now the drive will not open with either the front button or by software. I closed the music software and it still will not open. I can see the files with Windows Explorer and play the songs.

So, yes, I can still access the drive. The tray will not come out unless I reboot. This problem mainly shows up with music CDs or when installing software that requires 2 CDs. It has been doing it since I have had the computer (3 years) and with 2 CD drives. I did change the jumper from cable select to master. The DVD drive opens fine.

I am at a loss.


#6

May sound silly, but have you tried swapping the IDE cable for a new one?


#7

Interesting thought. I always thought the button on the drive worked directly with the drive software. If it works through the OS then it could be the cable, the ASUS MB, or perhaps the MB needs a BIOS upgrade.

I just tried taking out the DVD drive and using that part of the cable but same problem. Next I will see if there is a MB update. If that does not work I will try a new cable.

Thanks!


#8

Problem solved!

I checked with ASUS and there was one more MB BIOS update 1 month after the one that I had last installed. I updated the BIOS. Same problem. [I had forgotten what a pain it was to work with floppy drives and DOS. In hindsight, I should have used a CD instead of a floppy as the floppy would not hold the flash utility, the old BIOS, and the new BIOS.]

I then found an old flat IDE cable and installed it. Everything seems to work fine now. I just need to pick up a new round IDE cable and install it.

Many thanks for all the ideas and help on this one everyone!


#9

I’m actually not surprised. I have 40-wire IDE cables on another PC, and I swapped one out for an 80-wire one.

My LG drive that was in there at the time started behaving most strangely…one of the symptoms was the drive door doing weird stuff. I could eject it after a couple of tries, then I had to reboot in oreder to close it again.

Switched back to the old 40-wire cable, back to normal. Was obviously a dodgy 80-wire one.

Glad it’s fixed :slight_smile:


#10

I never suspected that the button on the front of the drive sent a signal to the OS through the IDE cables rather than operate directly on the drive. The cables that came with the computer are from when the round IDE cables first came out and are probably poor quality. I am replacing them both.

On another topic I also found a board that attaches to the back of one of my 300 GB SATA HDs that converts it to PATA IDE. I need more space on my second HD and am not using the SATA drives.

Thanks again for your “silly” thought!

:smiley:


#11

I just received the two new IDE cables. The CD is still showing the same intermittant problem. I am beginning to suspect it is a flaw in the MB BIOS. I suppose I will just have to live with it unless someone has another idea.

Any ideas?

[Since this has been a problem with two differnet makes of CD drives, perhaps it could be moved to a less specific forum where others might have additional thoughts?]