CD Doctor and aspi problem?

I just downloaded and tried to use CD Doctor with a Lite-On LTR-40125S but I get the following error message, “Exiting program because no cd-rom found” The drve shows up in my computer and device manager and I have no problems with nero not recognizing it. I reinstalled the latest ASPI drivers from Adaptec but still the same error. Aspichk.exe tells me that ASPI is properly installed and fully operational. If I manually uninstall the ASPI drivers, I get an error message about no ASPI layer found so cd doctor knows that the ASPI drivers are installed, it just can’t find my drive. I seem to remember having the same problem when playing with EAC also, using ASPI it couldn’t find my drive. I can’t seem to get the ASPI drivers working properly on my system, any suggestions?

tried ForceASPI?

I had the same hassle as you in this instance. I ran the .bat files of ForceASPI, restarted the system and problem solved :bigsmile:

Suggest using ASPI 4.60

That did it, thanks for the advice!