Can't write to higher speed dvd

Hi. I have a Pioneer DVD-RW DVR-104, that came with my Sony Vaio. The firmware i am running is version 1.30.

I recently bought a large batch of Imation DVD-RW’s that are 4x speed. However, i cannot write to these. The computer doesn’t seem to recognise the disc. (Using Nero 6 or Veritas CD Creator)

I tried writing to a 2x speed DVD-RW, and everything worked perfectly. I am guessing my drive cannot write to the higher speed DVDs. Is this likely to be the case, or have i bought dodgy DVDs? Is it the firmware that enables high speed writing, and if so, would updating it (if there is an update available) allow me to write to 4x discs?

Can anyone point me in the right direction? I don’t want to have to scrap the discs i have bought, but am a complete novice when it comes to DVD burning.

http://www.pioneerelectronics.com/pna/article/0,,2076_4273_128163990,00.html

Upgrading to the latest firmware should be priority #1.

I have tried upgrading the firmware, but i get an error message saying something like “Target is not available”. What does that mean?