Can't view or extract cd contents... (El Torito format I think)

vbimport

#1

I have a cd I’d like to copy files from. However from Windows it simply shows up as blank. Have tried several different image/iso extractor programs and they all show the disc as being empty.

However the disk has information on it. It will boot up using the floppy emulation and place you in DOS.

I think this disk was burnt originally using Nero. Have found one or two utilities that deal with the El Torito format, but the best I could do, was extract the boot image itself. I’m not so interested in that. What I want is the contents itself, and I know they exist on the disk.

Anyone run into this situation, or offer any advice? Seems what information I could come up with, that extracting it in Linux is easier. But I don’t have Linux or access to it, so it’s DOS and Windows for me.


#2

What drive have you used? I ask because some drives have limitations…

Have you tried with IsoBuster yet?


#3

Have tried the cd in 3 different makes of DVD reader/writer units. All the drives read the cd just fine, it’s that you can only see the contents, when you’ve booted off the cd. The cd is in some dos floppy emulation mode. Windows just shows the cd as blank.

Tried Isobuster and it’s no different than CDmage, PowerISO, MagicISO, Undisker etc. They all see what windows sees, which is “nothing”.


#4

What is your OS?
There is a program that is ran from a command prompt that Might be able to extract whats on this disc even if Windows shows it as blank.
Then it might just be a waste of time.
It is h2cdimage.
In it’s own folder you need :
h2cdimage.exe
wnaspi32.dll
I think both came with the zip I downloaded when I got it.
The other file with it is basically a readme in German.
the language it uses in the command prompt is German but it takes commands in English.
CD \ the command prompt to the h2cdimage folder.
I suggest C:\ for the location.That way you type cd \h2cdimage at the prompt & hit enter.
at the C:\h2cdimage> type h2cdimage.exe 0:1:0 filename -i
You will need to change the 0:1:0 to what fits your drive.
0:0:0 - master in the primary canal
0:1:0 - Slave in the primary canal
1:0:0 - master in the secondary canal
1:1:0 - Slave in the secondary canal
Let it work until it finishes.The reason I say that is it starts placing a dummy size .iso in the folder the size of the disc.It is only complete when the program finishes.
When it does you will have a filename.iso in the folder.Open that with any software that will open or prefferably mount an .iso like VirtualCloneDrive.
From a virtual drive you should be able to copy & paste the files on your harddrive.
Hope this helps.


#5

hi cholla. tried this h2cdimage thing, and it “read” the disc. I opened the .iso file and it’s “blank”. though I’m sure if I burnt the disc and booted from it, it would work. it seems the only way to get the files off, is to boot from it, then exit to the DOS command prompt. from there, using an old floppy drive or something, I may be able to get the files off, but so far it’s not looking to grand.

It seems like such a simple thing really. The disc was burnt using Nero, was made for floppy emulation, and yet Windows can’t see the actual contents of the disc. Really odd, but I know there must be some tool/utility or method out there to get the files.

The biggest drawback is by doing the dos copy to floppy method, I lose all the long filenames, and that could be a problem. And so far I can’t even do that.

You can duplicate this disc, and the copy will bootup and work just fine. So the data is being read, it’s just that it’s invisible to Windows. It’s only visible in dos and only when you boot off the cd itself.


#6

Probably the TOC and other important “indexes” were manipulated for some reason.


#7

Sorry it didn’t create an .iso that you could read.I think if you burned this .iso to disc it would work but that’s not what you’re after.
I suggested h2cdimage because you had already used other programs I would have suggested.
I’m barely even newb level on Linux.I have used a Linux CD made from an .iso you download from a site called TRK.I have only used it in a NTFS OS .I don’t have any idea what commands I would use to see if it would read a disc like yours.Maybe a Linux user will post some instructions.
I think chef & I are thinking along the same line.
My best guess is the disc is written in a “Floppy” format like FAT 12 or 16.
A Windows 95 or 98 OS might be able to read it.If it is in one of those formats it won’t have LFN (long file names).
I will see if I can find something more.


#8

The disc was burnt using Nero Express. And it was burnt using the Emulation mode which since I don’t have Nero installed, is a form of floppy emulation.

What is odd, is that when I make an .iso image of the disc. It’s 250mb. But when I boot off the cd and F5 to the command prompt, the total disc contents only show as 90mb.

I tried a program from InfinaDyne called CD/DVD Inspector. After analysing the disc, it gave this report…

The following information was collected by CD/DVD Inspector
Copyright 1997-2004, InfinaDyne

Table of Contents
There are a total of 2 tracks on disc, plus the lead-out.
Disc manufacturer: Plasmon Data systems Ltd. Type: Phthalocyanine (gold)
Track 1 occupies 127008 blocks (28 Min, 13 Sec, 33 Frames).
This track contains data in ISO-9660 format and also contains Joliet format directory information.
Lead-out track starts at block 127008.

Bootable disc information found, boot catalog at sector 20
Bootable disk from Arnes Boot Record, platform=80x86
Bootable (Hard Disk) load 1 at 0x7c0 from sector 27

Data track 1 recorded as part of session 1.
Volume create date 1/29/2009 13:09:00
Volume size appears suspicious, header says 127158 while track is 127008 blocks.
25 blocks are used out of 127006 blocks of space
Both the publisher and data preparer fields are blank. This should have somebody’s name in it.
This track has an application identifier of “NERO BURNING ROM”.
There are 0 accessible files and 0 directories contained in this track.
A properly written post-gap was found for this track.

Data track 1 recorded as part of session 1.
Volume create date 1/29/2009 13:09:00
Volume size appears suspicious, header says 127158 while track is 127008 blocks.
Both the publisher and data preparer fields are blank. This should have somebody’s name in it.
This track has an application identifier of “NERO BURNING ROM”.
There are 0 accessible files and 0 directories contained in this track.
The directory in this track qualifies as using the ISO-9660 character set.
The mastering program for this disc did not place version numbers (";1") after the filenames.

There are one or more conditions that make replication of this disc questionable.


#9

An update on this. After looking at this on and off for the past few weeks, and studying the .iso more, I think I’ve discovered a few things.

One, this .iso was made using the “Hard Drive Emulation” mode. Even though the data comes to about 80mb, the image itself is 250mb. So it’s possible a image was made from a 250mb hard drive partition that contained only 80mb of data.

The disk was burnt using Nero. The reason I cannot see any of the data inside Windows is because it’s all contained within the boot loader itself. Normally you would use Floppy Emulation that can use 1.44MB or 2.88MB image sizes, but since the burn method is Hard Drive Emulation, there is no size restriction.

Thus the data is only visible once the disk boots and loads the hidden image.

Using IsoBuster, I was able to see the boot disc details. It shows the .img size is 2mb, but actually it’s 250mb. IsoBuster simply cannot deal with the image size being bigger and thus takes a guess it’s a 2mb size.


As you can see in the pictures, there’s the boot loader info, and in the second what appears to be a “blank” cd.

I found references to mkisofs and how it can hide the file system when creating an .iso. I thought maybe my image had this done to it, but I don’t think it’s that complicated or as involved. My disc is simply one giant hard drive image, where the data is only visible if the disc itself has been booted of it.

Now that I think I’ve worked it out, the fun is then in how to recreate this effect :eek:

What do you guys think?