Can't update BIOS


#1

Well guys, haven’t had anything to ask for a while but I do now. I can’t get an ASUS F2A55-M LK Plus to update the BIOS. I went to Asus, downloaded the latest BIOS update, put it on a flash drive and tried to use the EZ Flash utility in the motherboard BIOS to update the BIOS. When I boot to BIOS, click on tools and click on EZ Flash[with the flash drive connected to the computer]EZ Flash opens with the info on the flash drive displayed. According to an article I found on the internet, with pictures, what is on my screen is exactly what was on the picture in the article. Just a different motherboard number. On both there was the name of the motherboard, BIOS version, with the extension .CAP So I highlight that listing and get a box that says “Do you want to read this file?”. I click “OK”. Then I get a message, “Selected file is not a UEFI BIOS!”. I tired it several times. Twice downloaded the BIOS update, yet got the same results every time.

So, I says, I’ll use AI Suite II. This is what I had used when I updated the BIOS on an Asus F2A55-M LK board in my other desktop. So I opened AI Suite and clicked on update, then clicked on ASUS update, and when the updater opened it had three selections. 1) Update BIOS from Internet. I click next and it gives me a server to download the BIOS update. I click next, it says connecting, then says “Network connection error! Please make sure you system is connected to the Internet.”, which the computer is connected to the internet. So I click back until I get back to the updater, click on “Update BIOS from file”. I have the latest BIOS version downloaded to my desktop so I click next in the updater. A window?? opens that shows the desktop and I select the BIOS update which is now shown in the updater. Then I get the message, "The model of the BIOS image doesn’t match the BIOS ROM currently present.

Well, the 5405 BIOS version is listed on ASUS’ site with eight newer BIOS versions. The lastest, the one I have is 6701 dated 11/20/14, cannot be installed. So I have to ask you. What do I have to do to get the BIOS updated to the latest version.

Am I going to have to download some older versions since there are eight newer versions than what I have on the board. If so, how to know which ones, or, will I just have to try to install all eight of the newer versions. thanks.


#2

And you are sure you have downloaded the bios for the plus version ?, can see the none plus used same bios numbering, but it ain’t the same bios


#3

Yes, when I went to the ASUS site I searched for the BIOS by board number and put in the Plus board number and downloaded the BIOS update listed. But I will try again. Thanks.

Later: I downloaded the BIOS update from ASUS. In the .CAP file that shows up in both utilities the word Plus is in the file. Tried to update again and got the same results from both utilities. Thanks.

Still later: You said that the BIOS update for the Plus and non-plus board had the same number but were different updates. So I went back to ASUS and downloaded the BIOS update for the non-plus board and it updated the BIOS. The board is a Plus board unless it is mislabeled. Thanks.