Can't Swtch Pio To Dma Mode In Xp, Pioneer A07 Dvd+- Burner

vbimport

#1

I can’t get my drive to burn DVD’s on a higher transfer speed (DMA Mode) after successfully applying the hacked v1.10 firmware for 8x for my Pioneer A07XLB - DVR107D. I need help with changing from PIO to DMA mode for the IDE channel, but it keeps returning to PIO mode in XP! The drive supports both.

I am using WinXP SP1, on 2TheMax motherboard 4SDA5+ and supposedly supports SIS648 chipset SIS963 IDE controller chip…

I’ve tried all the proposed methods,

  1. Deleting the IDE controller channel in Device Manager.
  2. Set PIO to DMA if available mode in Advance settings for the IDE.
  3. Registry Edit to remove the values for Master/SlaveIDchecksum data in the Regsitry for the channel.
  4. Change a new IDE cable for the optical drives
  5. Change the IDE 1-2 bus positions for HDD’s and DVD Drive (as primary)
  6. Swap Slave and Master for CDRW and DVDR± drives
  7. ASPI Layer drivers - Update/Downgrade to/from v4.6 and 4.71

Please Help! I have no idea what is the problem and all has been tried…

HELP!!!


#2

test2


#3

Hi GalacticMonkey and welcome to the forum:)

How do the devices show up in Bios? Have you tried upgrading your chipset/bus drivers or using MS drivers or vice versa?


#4

DMA enabled in BIOS?


#5

Is it only with this device or is it every device you have hooked up? Have you tried uninstalling the drivers for the devices and then having windows reinstall them? Don’t really think that’ll work but I’m not sure what else you can do. You’ve all the known working methods. It could be a problem with the hacked frimware you got put onto the drive. If it’s supposed to work with the hacked firmware then maybe it had an error or something when you put it on. If nothing works then maybe it’s malfunctioning.