Can't set DMA for DW1620

vbimport

#1

Whenever I try to set DMA in Windows for my brand new DW1620, the system won’t boot.

Here’s some relevant data:

  • Windows 98SE
  • Primary = 2x HD, secondary = DVDROM master + DW1620 slave
  • Both HD in DMA
  • The DVDROM will work fine in DMA mode in the same controller
  • Already tried DW1620 alone in secondary as master
  • Already tried flashing BenQ to latest firmware
  • Already tried removing and reinstalling secondary controller and drives in Windows

Other than this everything seems to be working fine and I already burned a few discs successfully, but for obvious reasons I’d like to enable DMA.

Suggestions ?


#2

Use the default microsoft ide drivers instead of chipset specific drivers. Attach a nero infotool text output as file to a posting.


#3

Change to the 1620’s P9 firmware as a starting point.


#4

Why??? :wink:


#5

There are known issues with older mobos (ie. VIA and nVidia) and DMA setting on secondary IDE-channel.

Identify your mobo and try to look at chipmaker´s homepage for appropriate drivers. :wink:


#6

It works ok for me with Nvidia 2.5 IDE driver… if this helps :slight_smile:


#7

Reinstalled Windows over the previous installation. Working.

… :o …

Thank you everyone.