Can't Rip Sony Dvd's- Setta Alpha error

Just wondering if anybody had an answer to why I can’t rip Most, if not all Sony Dvd’s. I get an error that states it has an invalid structure, and is Setta Alpha protected. I have DVD Idle pro, and DVD Shrink, which works with everything else I have tried. Any suggestions would be appreciated.

  • Sony is evil, and the most aggressive with copy protection.

  • what decrypter? Gotta stay current with Fab or anydvd for example. Don’t think idle pro is going to cut it by itself, and Shrink is just a ripper/compressor.

I do not know anything about Setta Alpha protected, so I would contact fengtao either as PM or Email fengtao@dvdidle.com.

Mack

I just went through this with Underworld Evolution. I tried the most recent versions of DVD Shrink, DVD Fab Gold, DVD Decryptor & DVD Fab Decryptor. None of them worked.

The solution as of this moment (6/27/06) was to dl the trial of AnyDVD & then rip with DVD Fab Decryptor while ANy DVD was running in the background. Hopefully DVD idle will have a new release out soon for this. AnyDVD said it found 2 different copy protections (one of them was something like Puppetmaster, I didn’t write it down) + fake bad sectors.

                             MooMooMooMoo

I spoke too soon. The rip freeze every few minutes. I’m going to mess with it a bit more, & then give up. I’m sure DVD Fab will have a solution soon.

                                 MooMooMooMoo

You’re probably getting sick of hearing from this forum newbie. In case anyone else deals with this, I was finally able to get a playable backup by running Any DVD & ripping with DVD Shrink. With Shrink both movie only & backup with menu saved & extras overwritten worked. Not sure why DVD Fab Decryptor’s rip caused the freezes, from my limited knowledge it appears to have been a time code issue of some sort, the files ripped to my hd were freezing the same way & at the exact same spot as the burned disc.

I saved the info from ANY DVD this time, in case it will help dvd idle with this issue:

RCE protection not found.
Found & removed wrong DVD structure!
Found & removed structural copy protection (Arccos, Puppetlock)!
Found & removed bogus title set!
Found & removed invalid VOBUs!
Autorun not found on Video DVD.
Found & removed 5 bad sector protections!
Emulating RPC-2 drive with region 1!

                            MooMooMooMoo

I started using DVDFab when DVDXCOPY, and ICOPYDVDS2 in combination with DVD43 would not copy Spanglish which had that same protection. Copied without problems with Express.

Mack

I downloaded the Any DVD, and it worked pretty well, although it was a little slow. Thanks for all the info, and have a great day. This is a very cool sight, which is now in my favorites.

i just got dvdfab express last nite used it on underworld 2 & bloodrayne no problems at all stuck the dvd in pressed start and wallla…i’m under the assumption is that everyone’s computer is different or writer…i have a pioneer 111d with the 1.19 firmware and the nero that came with it 6. something and everything worked perfect…i don’t know

oh yeah i used the vso burn engine though did not let it use nero and also use sony dvd+r 8x as my media

I burned Underworld Evolution using CSS free and   DVD shrink and had no problem at all!Try just burning the main title and not the entire movie, I've found that this works for quite often when having burning problems.

Just tried RipIt4Me and it is so nice :slight_smile: