Can't rip protected cd

hello to all the experts .
i got new audio cd that i wanna backup.
when i am inserting the cd into the cdrom i can see only track #1.
i tried to look for hidden files and i couldn’t find any.
i tried to rip the cd to mp3 but i can only mark to rip the first song.
all the other songs shows as data files and the program doesn’t know how to rip them.
after that i tried to burn the cd with clonecd but again the only song that work is song number 1.

how can i rip the cd into my computer and my IRIVER ??

Thank you,
Nir.

Try to use Exact Audio Copy

is Exact audio copy is program or option in the clonecd?
and i tried easy cd-da to rip the cd but he can’t rip the data tracks only the first song.

is a program. google to find it

i choose to rip all the files but every time the EAC rip only the first track…
any ideas?

Sorry, I’m not an expert on audio stuff :frowning:

Check on EAC oprions to see if there is something

thank you for your help anyway…
it doesn’t let me rip the data tracks (all the tacks exept track #1 which appears as music track)…

Maybe there is only one audio trask. Are you sure that the other aren’t video tracks?

yes when i play it in my home stereo i can listen to all 20 tracks.
when i put it in the computer cd i can only listen to the first track and all the others
are “data tracks” that i can’t listen too…
i can’t listen to it with my car stereo either…
i only want to rip the music so i can listen to it with my m3 player…