Can't record on DVD+RW disc

Hi, dumb newbie here…

I recorded some video on a +RW disc on my PC, watched it on my SONY 510 DVD recorder. Problem is I can’t erase or fomat the disc and when I try and record on it all I get is ‘this disc is unreadable’.

I have used NERO 6 OEM and ULEAD Movie Factory 4 to format it and quick erase, but still my SONY doesn’t want to know. I can use them as normal on my PC. ULEAD has several options for formatting in the UDF file format, none seem to make a difference, and I can’t find a finalise option in Nero.

When I put a fresh DVD+RW into my SONY it formats it first, I was just wondering if anyone had any ideas about what file system or how to fix it. I’ve gone and run out of discs to record off TV. :confused:

Thanks

Sony standalone DVD recorders like the 510 are well-recognised to have problems with +RW discs formatted on the PC. Unfortunately the only reliable thing is to keep a separate stock of +RWs for the Sony, and ONLY use them for READING in the PC.

If you know someone with a Philips machine, these will accept your PC-formatted +RW discs and offer you the opportunity to re-initialise, after which the Sony should then accept them. This worked for me with a Philips DVDR880 and a Sony GX3.

It just so happens my old recorder is a Phillips R80. It’s all but unusable for recording, but for formatting some +RW’s it should work. I’ll give it a go as I don’t recall this happening when it worked.

Thanks :clap:

Use DVDInfo to format RW media properly.