Cant recognize dvd-movie-discs on SOHW-1653S

vbimport

#1

Ok got myself a SOHW-1653S, installed it while following instructions as precisely as possible, patched the firmware with the latest official one (the christmas one), before that backed up with eeprom and also firmware, and all seems fine, plays cd’s and dvd’s, but fails to recognize a dvd movie. INserting dvd disc it converts from regular DVD-RW Drive sign from My Computer into CD Drive one and cant open it. At some point I thought its a region issue and noticed I had no region set in Device Manager, so gave it my country’s region (which should play most dvd’s Ive bought here at least), but still nothing.

Help?


#2

The best I got it to do is trying to read the movie disc, but having those crunchy sounds. My Computer displays nothing still. I wonder if liteon hates me, as Im having a bad streak with their damned drives…


#3

I see many have viewed the thread but no suggestions. However, what I did was that I uninstalled any dvd related stuff on my system (including nvidia dvd decoder I tried during my 851s problems), removed all odd drives and rebooted. Apparently I got one movie working now, without a single glitch or problems, and tests look good so far. Will check some other dvd-s, and how it tries to handle dvd’s not from this region.

As far as regions go, can someone tell me what would be the next best step in getting my drive actually region free? I read some topics about some rpc1 and such, but I really dont want to self experiment costing me another hundred bucks. Or link me to some website or thread that gives a good description, since I read in this forum that many have had problems with region self experiments and Im not in the mood for those myself.


#4

Alright Ive currently checked the following DVD’s:

WORKING
The Last Samurai - Region 2 and 5
The X-Files The Movie - Region 2
Master and Commander - Region 2 and 5
Saving Private Ryan - No region marking (probably 2)
The Fellowship of the Ring (theatrical) - Region 5
Return of the King (theatrical) - Region 2 and 5

NOT WORKING
The Matrix - Region 5
The Matrix Reloaded - Region 2 and 5
The Matrix Revolutions - Region 2 and 5
Forrest Gump - Did not find region marking (most likely 2)
Extended Editions of the Lord of the Rings trilogy - Regions 2 and 5
The Two Towers - Region 5

Well, if anything, Im really confused. I region-freed my drive with LtnRPC and the disc-check program said that no lock detected. Also have Regionkiller and DVDGenie on. Most of these not working ones are not detected and change the label to CD Drive.

Help, please? Somebody? Something?


#5

Riight…

After a day messing around with it, being as careful as possible, I really dont know what conclusions to draw. Couple of dvd’s, like matrix reloaded, does this clinky sound, as if it cant load it at all. Others that cant read well just change my computer’s icon into cd-drive. The ones that read well, read without a single glitch or problem, and theres no problem writing nor reading data discs (only thing I havent tried is writing on DL disc, since I dont have such at hand).

Rechecked my cables and IDE’s. Ive got two drives in my system, both are writeable (even if the sheet says it may cause a conflict, I dont think its read related). DVD is on master, CD one, also liteon, is slave, both on secondary IDE. ASPI is on 4.60. I also uninstalled nero and all sorts of dvd related software from my computer, hoping that I can find something that lets me at least run the dvd movie files. WIth this situation, I can load the dvd’s I could load before, but cant play them (no decoder). This isnt an issue of course, since Im trying to get the other dvd’s working, which still wont read. Also eliminated DVDGenie (uninstalled, but it still seems to be on). THe only thing Ive got installed, dvd related, is region killer.

Help, please? c0deking?


#6

Sorry to hear this drive is giving you an issue as well :sad:. It’s one of those things that is very tricky to pin down. Is it something in the system or the drive :confused:. The ultimate way to prove it, is to try the drive in another system. Have you used these discs (the unreadable ones) in a PC drive before. Are they new or second hand discs? Are they original pressed dvd movie discs?


#7

Yes, every dvd movie I have is original and retail bought. And yes I have used them on my computer before, on that dying 851s, before it had its problems everything worked fine. The current drive gives me no problems, I tested out two dvd movies at full length last night, and the only pause I had was during the warner brothers opening credit on one of the two movies, that paused for a less than a second. THe rest of the movie played perfectly, and when disc was inserted it loaded up just like it should. Smooth sheeeeeeeewww and bang, autorun. Im not sure why the other discs cant be run at all.

And yes these discs can be called new. Im one of those medium freaks who uses cd-cracks on games and keeps cd’s themselves piled up on shelves, and every disc I have is more or less scratch-free and in perfect condition.

No I havent tried it on another system, since I dont have one at hand, but I might get an option to do that some time soon.


#8

Some revolutionary updates…

I did something stupid, I tried using mtkwinflash thing, trying to update my drive back to the old firmware cs02 (since somehow windows flasher never told me that it completed and drivers firmware showed still cs09). It said soe flash type error and I couldnt close the program. So I forced it to shut down manually. With this however, trying to reflash the drive with windows flashing tool, it didnt detect my drive anymore. None of them. I thought hey, my drives murdered now.

It wasnt, a restart resulted in my liteon cd-rw burner being failed (the other one), while the dvd one has no problems playing the dvd’s it didnt manage to play before. Hopefully I can get my cd-rw back working again. I have no idea what happened in the meantime… And no I didnt try to flash my cd-rw, I made sure its dvd-rw I tried to flash…

However I cant understand why my other drive is disabled now (and I cannot enable it). Its an LTR-52246S CD-RW and has worked perfectly up until this strange day. I cant see how could anything Ive done actually influenced this, but my DVD-RW is fine now, plays anything (cd/dvd shaped of course lol), while the dvd-rw and virtual drive got disabled… Really really strange


#9

Does your DVD burner have CS02 now ? Anyway, using mtkwinflash causes trouble all the time. If I remember right, it does not support DVD burner at all. Recover your cd-rw with the DOS mtkflash (booting dos instead of windows), see the FAQ for details. Disconnect your DVD burner during this procedure to be shure you flash the right drive.
You should also reflash your DVD burner with ltnfw, set the update bootcode option while burning.


#10

Yes its says its cs02

But I cant understand how can my CD-RW have problems now. This thing also disabled my virtual drive of daemon tools, and if they both show on device manager then they cant be totally dead imho…


#11

Well, your recommendation ala42, reflashing my drive with ltnfw managed to get my dvd-rw into the same damned position as the other drives. All are disabled and I cannot enable them. If I press enable windows says it cannot enable them (but the right click command gives me the option of disable, though its already disabled).

Now Im without any ODD drives at all…


#12

Well, there are other things you can enjoy in life, just try it :slight_smile:
In the mean time, post the text output of nero infotool as text file attachment so we can have a look at your config.


#13

This aint funny, I had it working and reflashing has screwed everything… Just bought the damned drive…

Anyways I added the infotool log file. I tried mtkflash but didnt go through with it. I made a boot disc (following c0dekings commands in one of the other threads, but using 1.83c). Deleted everything but the three files c0deking had pointed out, added the 1.83c executable and typ file, and the original bin. I didnt continue since when I typed in mtkflash c, to check the drives, it typed out:

1: secondary master
2:secondary slave

or something. This seemed weird as according to some other posts it said that secondary master should be 3 and slave 4, and I didnt dare to use mtkflash 3 w /m cs02.bin to ty and see if Im lucky…

I also dont really understand how come my drive is dead really, its identified correctly in nero, worked before reflash, and I cant now even get virtual drive to show up…


#14

I would like to thank EACH and EVERY ONE OF YOU who replied to this or the 851S thread.

THe recent thing, of not recognizing the drives, was a strange strange thing, probably caused by infamous mtkwinflash thing. Something went wrong and none of my drives except the dvd-rw was not recognized. Now I know why dvd-rw was recognized and others were not, the reason was that computer took it as a new drive and installed drivers for it. Apparently, when I reflashed it, computer took it as with the other drives, and because of some software malfunction, none of the drives were read.

THe solution to this problem was obvious (and I can see why nobody suggested it, as it was so obvious). I had to uninstall the drives from the system, and it reinstalled them on reboot. Everything works now, from dvd-rw to cd-rw to virtual drive and everything else.

So, now that everything seems to be running so fine, I want to thank you all for helping me in need. Special thanks to c0deking and please (its harder each time to use this username in sentence :stuck_out_tongue: ).

This was a valuable experience, since Im studying computer science and will go all round IT related things, including hardware and computer full from scratch setup. This comes in the end of this year though, so Ive got time to cause some extra probs in my computer, and hopefully some with ODD so I can return here for assistance :slight_smile:

You guys have been great. Thank you :slight_smile:


#15

Nice :). You should update your nero to at least 6.3.1.20 because of your XP SP2.


#16

After uninstalling anything odd related, I installed Nero OEM that came with the drive. Ill get full nero next week from my office.