Cant read from burned cd with pictures :(

Hi I have a problem with a cd I burned in Bolivia, I hope some can help.
The problem isnt that the cd is scratched and I burned to copies of it and they both give the same error message when I put them in my drive, they worked fine in Bolivia.

I was on holiday in South America, and took pictures with a digital camera, and burned the pictures to cd’es, but the cd’es I burned in on shop dosnt work on my computer, they did work after I burned them, I tested them right after.

If I put the cd in my drive, it says that the cd is empty or that it cant read the cd. But I cant burn anything on it, so it isnt empty.

If I use a program called badcopy, it can see that there is a track 1, but it says that the track is 879 mb and it cant restore it

When I use cdched I get these errors

  1. error;win32;The parameter is incorrect. (code: 87);E:\
  2. critical;process;File/directory in setup window not found! (code: 2);E:\
  3. critical;process;Process aborted! (code: 3);

Íf I try to run the cd from dos I get the message: parameter is incorrect.

I also tried Isobuster and several other programs.

I was wondering if I maybee could burn the cd to a nother cd, but no program I have tried can burn it, cause they say it is empty, and no program can restore it because they say its empty, somehow the filesystem is badly damaged, but I have no idea why.

I would sooo much love to get the pictures back, so if any can help, this reply, and I will be forever gratefull…

Thanks…

879 mb on one CD ? that’s odd, because even the oversized CDs are 800MB/90Min…
sorry, you’ll have to wait until someone more knowledgeable than i turns up…

Anyone else, that have a comment for this strange thing that happenede to my dear pictures ?

Thanks

What sort of machine were they burned on? Mac, perhaps? What software was used to burn?

Have you tried taking it to a photo place?