Can't open AcomData firewire hard drive enclosure

[qanda]This thread is about the AcomData E5 hard drive - 160 GB - Firewire. Click here to see full specs[/qanda]My hard disk apparently died, but I can’t figure out how to open the enclosure to replace it. Can anyone help me crack this oyster?

PS- Sorry if this is a dupe. I’m new to the forum and getting used to the interface.

I had the same issue with my 320GB Acomdata FireWire Drive on my I-Mac. To open, you have to pry the aluminum plate off of the switch end of the drive which is hiding the four screws holding the drive inside. Use a slim flat blade screw driver to wedge between the plate and black plastic and the aluminum plate it will come off. Why Acomdata hid the screws is anyones guess.

I installed my drive into a USB enclosure and tested it and it worked fine so I scanned it with Spinrite drive recovery software (well worth $79) and the drive checked out fine. Reinstalled it into FireWire enclosure and drive worked flawlessly.

Hope this helps.