Can't install W7 x64

I have a 760GMA-P34 (FX) motherboard. I loaded W7 Pro x64 and everything was working perfectly. I decided to load W10 Pro x64 to see how it would run on the board. I then tried to reload W7 Pro x64 and it won’t load. Get the following message: Windows cannot install required files. The file may be corrupt or missisng. Make sure all files for installation are available, and restart the installation. Error Code" 80070017

No x64 OS will install on the board but I can install any x86 OS. Anyone know what happened and how it can be solved. Thanks.

Usually means Bad Media

There is really not much point in installing Windows 7 given Microsoft stops support it with security fixes etc in Jan 2020, which is 4 months from now. so you might as well move to Windows 10 1903 (which is the newest version of Windows 10) or try a Linux variation (I prefer Linux Mint (Cinnamon)).

Maybe a RAM-problem?

If you can read the whole Windows-DVD (copy files to HDD/SSD) or the transfer-test in CDSpeed shows you if it is really a media-problem

I understand the code usually means that but I tried three different ISO’s that I had downloaded for the internet, even ordered an install disk. Thanks.

Thanks for the reply, and I will use W7 until then. I am moving to Linux Mint but have having a learning curve moment. I can install and use Linux with no problem but there are some other aspects of Linux I have still learning. The main reason that I haven’t switched to completely to Linux is that I have over 3000 .wps files that I can find no word processor compatible with Linux that will open the files without losing the format. But with the loss of support for W7 I will have to use Linux and manually reformat the files in the word processor that comes with Linux. But I will probably just run W7 in VB for the files without connecting to the web. I refuse to use W10 and am fed up with Windows.

The other big issue is that you have to do a full format of the disk before trying to reinstall Win 7

Thank for the reply. But I ordered a new HDD and the OS installed. Don’t know why it wouldn’t install on the other two HDD’s that were almost new but had had other OS’s installed before.

Sorry for the long wait on replying, but I was waiting for a new HDD to arrive. W7 installed on the new HDD without problem. I have worked on computers for years and never had a case where one architecture would load but the other wouldn’t. Oh well, W7 is installed on the new HDD and the reason for it not installing on the others is something for me to try to figure out.

You can return a HDD/SSD to a ‘new state’ by doing the following.

goto command prompt with admin privileges and type DISKPART
type list disk
And note the number of the disk that you want to use. Be careful to note down the correct disk number.

type select disk
(followed) by the disk number you noted from before.

example select disk 2

type clean

Or you can use a live linux distro, and use GParted to clean the disk by removing ALL the partitions.

The easiest way would be to delete the partitions in the Win7-Setup. Write to zeros isn´t necessary


I remember a similar problem long time ago with XP and an Abit NF7-board. Always a strange error-message if I try to install it on a WD-HDD. I switched to a Seagate and it worked.

But Abit-Mainboards were awful with the 1st Bios; with this mainboard a AOpen CD-ROM-drive won´t open the tray if the PATA-cable was connected; with power only the tray opened