Can't install any drivers or apps on LDW-851S getting KERNEL32.dll error mesg

Hello,

Problem: Windows XP Pro installs OK via LDW-851S

However, when I try to install my Asus motherboard drivers I get,
“The dynamic link library Kernel32.dl| could not be found in the specified path
F:\Bin;.:C:\WINNT\System32;C:\WINNT\system;C:\WINNT;C:\WIN NT\system32;C:\WINNT\System32\Wbem.”

when trying to install ATI video card driver,
“The procedure entry point mixerGedDevCapsA could not be located in the dynamic link library WINMM.dll”

when trying to install Norton (purpose just trying install any application to see if it can get anything to install) I get message to: “The procedure entry point WriteFi|e could not be located in the dynamic link library KERNEL32.dll.”

when I try to install any app,
“The procedure entry point XXXXXXXX could not be located in the dynamic link library KERNEL32.dll.”

So the problem is I get those system error messages and I cannot install any driver or application.

Setup:
AMD Athlon 64+
Asus K8V with Via K8T800 chipset
Kingston DDR400 1GB RAM
ATI 9600XT videocard
Seagate ATA100 160GB HDD
Samsung CD-ROM on 2ndry IDE and jumper set to “master”
Lite-On LDW-851S on 2ndry IDE and jumper set to “slave”

OS: Windows XP Pro with SP1 and latest updates from Microsoft.

Obervations/Actions taken:

  1. Windows XP Pro or Windows 2000 installs OK on Lite-On LDW-851S
    (Samsung drive not present in system)

ALL applications/drivers fail to install with messages above on Lite-On LDW-851S
(Samsung drive removed from system).

ALL applications/drivers installed from Samsung drive or from Hard Disk drive install OK.
(Lite-On LDW-851S removed from system)

  1. I formatted my C drive three times and reinstalled Win XP Pro twice with SP1
    and went to Microsoft and installed all critical updates…same errors above
    (Samsung drive removed from system).

  2. I formatted C drive again tried installing WIN2000 w/ default SP2…I still get same
    error messages above. (Samsung drive removed from system).

I check the C:\WINNT\system32 directory, KERNEL32.dll and winmm.dll are
present in the directory.

  1. When Lite-On LDW-851S is on 2ndry IDE and jumper set to “master”
    while Samsung drive is set to slave, Windows does not see Lite-On LDW-851S. (Both drives present in system).

Anyone have ideas? Thank you in advance…

same issue…but I found out that when I use PIO mode on 2ndary IDE
I can finally install apps. As soon as I switch back to DMA mode,
I get the kernel32.dll errors

I also replaced this unit once and same
problem…only workaround is to go to
PIO mode.

Could this be a motherboard problem???

Originally posted by quack724

Could this be a motherboard problem???

Have you installed all necessary chipset drivers ?

Your LDW851 should be connected on secondary “master”…

:smiley:

BTW, SP4 is out for Win2k Pro…

did you try changing the drive seting it to cable select ?also are you using an 80 wire cable and is it plug in right,sometimes liteon’s do not like being a slave the cable have a motherbd.end and a drive end,check if this

Install SP4 prior to installing ANY drivers or applications.

Everyone…

Thank you for your replies…

In summary I have

  • ran Norton AV 2004 with latest definitions in win XP Pro safe mode today (not using win2K anymore)
  • flashed latest BIOS for K8V MB
  • verified BIOS settings
  • uninstalled and reinstalled 2ndry IDE controller (when windows detects,
    it reinstalls with PIO mode by default).
  • tried both 40 wire and 80 wire cable
  • tried both master & cable select
  • reinstalled chipset drivers

Questions:

  • any other suggestions?
  • is it possible to use Lite-On LDW-851S in PIO mode? if yes, will
    I get reliable data backups?

Thanks again…

don’t know about the other questions - that’s for others to say. What I can say tho is that PIO mode sux for anything other than copying miniscule files like txt files. Its dreadfully slow and will make ur burns take forever and a day, and not too nice on error rates.

I had my set up verified by local PC installer.

The tech reinstalled XP Pro w/ SP1 and
tried several drives.

he said that with a Toshiba DVD-ROM (not sure what model # it is), he could get DMA mode to work but with the Lite-On DVD burner, only PIO mode would work.

He also said that he uses PIO mode at home and has no issue.

So it does not like a burner or Asus K8V Motherboard issue…

Questions:

  1. could this just be a firmware issue or perhaps I am just stuck with PIO?

  2. Anyone out there running Lite-On burner is PIO mode? any issues?

He also said that he uses PIO mode at home and has no issue

Clearly you need to find a new repair person.
There are occasional reports of DVD-ROM drives that refuse to share with burners, and cause DMA problems. But there is absololutely nothing in the burner that can cause this. DMA is a controller function. If you are running any VIA-type IDE controller drivers, suggest removing them and running only MS drivers. Run the burner as master, alone on the channel untill this gets sorted out.
PIO is clearly not adequate for any current burner, DVD or CD either one. This is either a driver or setup problem.

rdgrimes, I think you are right re: my PC installer.

I think I am having a similar problem to user onthelash based on this recent post…
http://club.cdfreaks.com/showthread.php?threadid=91761&highlight=PIO+AND+LDW811S
but onthelash is using SIS chipset while I am on the VIA K8T800 chipset.

Questions:

  1. Could this be more of a win XP issue?
    http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3B817472

  2. Please pardon my lack of know- how…but how do you remove VIA IDE drivers and use only Microsoft IDE drivers?

Under IDE ATA/ATAPI controllers in device manager I see three items,

  • Primary IDE channel
  • Secondary IDE channel
  • Via Bus Master IDE controller

Do I select Secondary IDE channel and update driver and/or Via Bus Master IDE controller and update driver?

Via Bus Master IDE controller

Look under the controller properties at the driver versions, you’ll see VIA. These get installed when you use the MB maker’s disc to install the chipset drivers. Reverting to MS drivers is simple, but not always successful, you just use device manager to update the driver and force it to select the MS drivers (choose from a list). Using the XP install CD is sometimes possible if you know where the file is located on the CD. But the driver is already present on your HD too.

Yes, this might be partly an XP issue, but all you can do with that is remove the controller (uninstall) and reboot.