Can't get new Catalyst drivers from ATI?

vbimport

#1

I go to www.atitech.com but can’t download any software or even register my x700. Can someone check if you can get past ATI’s home page so I can tell if it’s my network or firewall or something?
Thanks.


#2

I have no problems downloading from there. Do you have Microsoft .NET Framework installed?


#3

Yup, tried that on the other two puters. Then I spent the last hour running the cat5 cable to my living room from the basement to try the one with the x700 actually installed on it. Same results. Other than the new Catalyst suite, I don’t really need anything from ATI. Any other ideas on how to get it? Tried to google Catalyst and no matter where I go, I can’t download it. Seems kinda strange, but the three cpu’s were all just given Norton Internet Security 2005 cause it came with the mobo for the new cpu and I kinda liked it. Think that could be it?


#4

Try booting into safe mode with internet support, make sure that your Norton isn’t running, and try to download. It sounds like either a hardware or software firewall issue, and you will have to look through quite a bit of stuff to find it. I had similar problems with McAfee, and had to dig for awhile before I found the settings that I needed to change. Since then, I’ve had no problems…


#5

Hey, thanks a lot. That sounds like the best idea yet. I have 3 computers, and all of them recently were given NIS cause it came with the mobo cd from new cpu. Since it doesn’t work on any of mine, but I can download from work, I was looking for a common variable at home. Work cpu doesn’t have a cd burner and I have limited usage available. The only common variables at home are: NIS, road runner modem in basement, linksys router in basement, (both were reset), and the fact that all 3 puters have Win xp home w/out service pack 2.

I looked through the blocked sites list in NIS and could not find www.ati.com. Tried to disable everything possible in NIS and got same results. Only thing I didn’t try is reinstalling NIS or booting into safe mode.

Three days ago I got to ati.com and would have been able to download, but I hadn’t hooked up the new cpu up in the living room yet. Now ati.com doesn’t work (I get to a msn search page saying “can’t find ati.com”). Atitech.com does work however, and then I can’t get past the home page.

Two of the three cpu’s went through a live update in NIS. The new one didn’t and it gets the same result.


#6

I’m pretty sure it’s not Norton Internet Security…I’ve been using it for almost 2 years now and never had a problem with it.

I don’t think uninstalling would make a difference, but you can try.


#7

You could try these drivers, or look on right of page for catalyst drivers. :slight_smile: :slight_smile: :slight_smile:

http://downloads.guru3d.com/download.php?det=923


#8

I actually tried guru3d.com and the download did not work. I got the same white screen, cannot open page… That’s what I find so strange. Everything else seems to work fine.


#9

It is Friday the 13th you know…


#10

Just went back to Guru3D and today I was able to get the Catalyst v5.4. It worked on the P4 1.8 gig that I got from a friend. My third cpu which also did not work yesterday.

Funny that I just wiped out my old one to reistall via Drive Image made on the 2nd of May. No big deal, only 10 days ago, backed up a few things and away it goes. This will bring me back to before when I could actually get on ati.com and download the drivers. Seemed like a last resort, and then it worked on the other one. I went to Guru3D yesterday with no luck. On all three cpu’s.
Oh well, it’s over now. Thanks for the help.